NVIDIA OpenGL Driver error code 3 (subcode7)

Blender crashes on startup with NVIDIA OpenGL Driver error code 3 (subcode7).

I referred to the event viewer, and I got an error like

“Unable to recover from a kernel exception. the application must close. error code: 3 (subcode 7) (pid=11244 tid=1144 blender.exe 64bit)”.

The following are workarounds I tried, but they did not work.

-Change the power settings from the NVIDIA control panel.
-Uninstall the NVIDIA driver with DDU and reinstall other drivers.
-Install/Uninstall chipset drivers
-Place OpenGL in the same directory as Blender.exe
-Install another version of Blender.
-Disable HAGS
-Disable rBAR
-Clean install OS.

PC configuration is as follows

OS : Windows11 Pro
MB : Asrock Steel Legend B550M
CPU : AMD Ryzen 7 5700X
GPU : NVIDIA GeForce RTX3060 (studio 551.23)
RAM : DDR4-3200 16GB x 2

How can I solve this problem?
What causes this error?

Thank you.

Hi @usagi_0722, welcome to the NVIDIA developer forums.

Please do not cross-post. Or at least mention that in the respective posts that you did.

This specific error code is quite well known to be associated with several possible configurations.

  • Over-commitment of GPU resources to several GPU-“hungry” apps
  • insufficient resources for the apps used (not enough RAM, CPU cycles, disk speed/capacity, …)
  • wrong driver versions in comparison to app requirements (The GPU driver might be too new for the Blender version you use)

And a lot more. For example RAM overclocking. Do you have EXPO (or DOCP) enabled?

Too much “fixing” can also have negative impact. Manually moving OpenGL libs or executables is not a good idea. Disabling Resizable BAR when working with tools like Blender is not a good idea.

Thank you for your response.
I am a little confused and sorry for cross-posting.

As for the GPU over-commitment, I am not familiar with computer details so I don’t really understand it. However, I don’t think it is a lack of capacity or driver version issue.

Checking the task manager, it appears that there is plenty of capacity.
I have tested various stable drivers, including the 400s driver that originally included with the GPU, and the error still occurred.

I have not overclocked or changed the frequency of the RAM. I have also had the RAM checked at the link below and it seems to be fine:
[link: https://www.nvidia.com/en-us/geforce/forums/game-ready-drivers/13/536634/blender-crashes-on-startup-with-nvidia-opengl-driv/]

As for OpenGL, I only tried it because it was suggested as one of the causes of Blender crashing. However, the root cause seems to be different, so it did not have a significant impact.

Resizable BAR was disabled from the beginning, so I tried enabling it, but there was no change.

Most of the time I initialized the PC and tried to troubleshoot and identify the problem, but unfortunately I could not find any clues to a solution.