Nvidia Prime Render Offload- Performance gets tanked when undirect fullscreen windows is disabled (Gnome) , Full Screen Repaints is enabled (KDE)

Both options above does the same thing. It is just naming of it and how it is being enabled by default or not is the real change here. Issue is Prime Render Offload specific, does not occur on Nvidia Only Mode.

Disclaimer: I am currently using KDE so all explanations will be towards to it but i also reached out to another Prime Render Offload user and we have confirmed issue also exists there (Gnome) too.

Scope of the issue:

Only few select OpenGL Unity games are affected , which are noted down below. I have tested many other apps ( both native and Proton based ) , affected apps noted below “Issue” section. Rest works well. Other tested, NON AFFECTED apps follows as :


  • Euro Truck Simulator 2 (OGL)
  • Half Life 2 (OGL)
  • Shadow Warrior (OGL)
  • Rome Total War Remastered ( Vulkan)


  • Red Dead Redemption 2 (Vulkan)
  • Doom 2016 (OGL and Vulkan )
  • Grid 2 (DXVK/Vulkan)
  • Titan Quest Anniversary Edition (DXVK/Vulkan)
  • Wolfenstein Old Blood (OGL)
  • Wolfenstein New Order (OGL)


When “Full screen Repaints” options is enabled on Compositor settings, framerate gets tanked on few select Unity OpenGL games.

Screenshot of where it can be enabled/disabled:

Affected games and change of their behaviours will be shown below, high FPS and stable frametimings were achieved with “Full screen Repaints” options being disabled, lower fps and inconsistent frametimings were achieved “Full screen Repaints” options being enabled:


Poly Bridge:


Nv bug report log:

nvidia-bug-report.log.gz (485.7 KB)

Non affected Unity titles follows as:

  • Helltaker
  • Firewatch
  • Never Alone (Kisima Ingitchuna)
1 Like