Nvidia problem

Since we got Asus Z270 Prime -A , 7x PCI-x slots + 1 M2 (can be used). So we setup 8x 1070 ,enabe 4G decoding and setup PCIx to GEN2 (Tried na GEN1 --same) and start linux.

What i want achieve is all 8 1070 run at 130W stable with overclocking and autorun script(use crontab).

sudo nvidia-xconfig -a --enable-all-gpus
sudo nvidia-xconfig -a --cool-bits=28
sudo reboot now
sudo nvidia-persistenced --persistence-mode
sudo nvidia-smi -pm ENABLED
sudo nvidia-smi -pl 130
nvidia-settings -a "GPUMemoryTransferRateOffset[3]=800"
nvidia-settings -a "GPUGraphicsClockOffset[3]=100"

Went ok.:

https://ibb.co/cDd5Hv

so i run miner:

https://ibb.co/fGZFja

As you can see ,persisted mode is on, TDP limit is added but VGA 0 is problem. Does not listen to TDP limit, and speed of mining is way too low.

So i tried with setting :

sudo nvidia-xconfig  --connected-monitor=DFP

and this worked:

https://ibb.co/dtXnVF

BUT

When no monitor connected i have problem:

nvidia-settings -a "GPUMemoryTransferRateOffset[3]=800"
nvidia-settings -a "GPUGraphicsClockOffset[3]=100"
ERROR: failed to connect to mir failed to connect to server socket no such file or directory. unable to init server. Could not connect: Connection refused

which means that xwindows has not been started at all!!

Is there any solution to this? i Really need this to work without monitor.

Maybe:

Option        "RegistryDwords"

Regards,
Luka

Hi Luka, did you ever solve your problem? If so, could you explain how you did it? I get the same error, and I would like to use the above nvidia-settings controls without using a monitor. Thanks! Dave

Try the ConnectedMonitor option in xorg.conf.