Nvidia proprietary driver causes network ping issues

As of a few days ago, when I use the Nvidia proprietary driver (Versions 470 and 495 both have the issue) and do something like open Steam, open Firefox or maximise a window, the ping time between my PC and my router spikes to between 1000ms to 3000ms. This only happens on wifi, both 2.4 and 5ghz, but not with a wired network connection.

I’ve tried this on Ubuntu Gnome, Ubuntu Budgie, Zorin OS, Elementary OS and Manjaro. All had the same issue when using Nvidia’s proprietary drivers. I’ve also tried upgrading and downgrading the Linux kernel, but it didn’t fix the issues.

Here is the ping spike caused by maximising the terminal window.

Ping spike

  1. Open terminal and start a ping from my PC to the router.
  2. Maximise the window, open Firefox or open Steam
  3. The ping time will spike to over 1000ms

As well as the ping issues, while on wifi and using the proprietary driver, many online game services don’t work. E.G I launch Battlefield 1 but EA Origin says I’m not connected. If I launch a Ubisoft game, Ubisoft Connect say’s I’m not connected. If I launch Rocket League, Epic Online Services says I’m not connected. Steam and all other internet browsing works.

I know it’s the Nvidia proprietary driver causing the issue, because if I switch to the open source Nouveau driver then the network issues stop happening. If I switch back to the proprietary driver then the issues return. I’m certain that this isn’t an issue with my router or my network configuration. My GPU is a 1660 Super.

nvidia-bug-report.log.gz (306.9 KB)

Have you tried moving the wifi card to another PCIe slot?

@leigh123linux The WiFi card is built into the motherboard (asrock B550M ITX AC), I can’t move it to another slot

Is the antenna attached right to the case? Can you extend it with a cable to move it away from the nvidia gpu?
The logs let me suspect EM interferences when the nvidia gpu is clocking up. The nouveau driver can’t clock up so the wifi issue is not appearing

Thanks so much for your help. I got some antenna extension cables and moved the antennas away from the PC and the issue is fixed now. I had no idea that it could be an interference issue.