Nvidia Px2 Ros Cross Compile Error

Hello,

I was following the instructions below to cross compile ROS with my host laptop to the px2:

https://devtalk.nvidia.com/default/topic/1032206/faq/drive-px2-ros-cross-compilation/

When I run
drive-t186ref-linux--<build_id>-xenial-ubuntu-rootfs.run

I got the error:

date: invalid date
ln: failed to create symbolic link ‘S01nv-run-date’: File exists
.install/drive-t186ref-linux/xenial_ubuntu_rootfs_startup: Installation cancelled, error in: setup_rootfs.sh

I try to understand the error, I have read some problems with time zones not being UTC/GMT, so I try different time zones but the same result.

Please advise.
Thanks in advance

Dear ugur.yavas,

Looks like the installation is not done on a clean environment. Could you please clean up the environment and retry?

We have cleaned up the environment and started from the beginning. But,the error is still continuing.

After install NVIDIA SDK MANAGER,

we have noticed that drive-t186ref-linux--<build_id>-oss-minimal-pdk.run file does not exists.

Instead of this file, we have drive-t186ref-linux--<build_id>-oss-minimal-sdk.run file.

Might it lead to the error?

Please advise.
Thanks in advance

Hi again,

After cleaning up the environment, reinstalling ubuntu, we have arrived to the stage:

$ sudo apt-get install python-rosinstall-generator python-wstool python-empy

However, I cannot find these packages. Besides, I have a apt-get update error to the arm64 directories.
Error is similar to:

I have looked around Nvidia forums, apparently, some Jetson users come up with the same issue, I tried their approaches but no luck.

https://devtalk.nvidia.com/default/topic/1002140/jetson-tx2/apt-get-update-errors/

Any advice to fix apt-get update error? For clarification, I get the error in the host side.
Thanks in advance,
Regards,
Ugur