nvidia quadro display hangs

Hello everybody,
I have this setup: Scientific Linux 6.1 64 bit, NVIDIA quadro 4000 with nvidia proprietary drivers 310.32.
The monitor is a 2560x1440 only resolution via Display Port.
I followed the right procedure to install the proprietary drivers(deinstalled nouveau ecc)

When I boot up the pc there are about 20 seconds when the monitor blanks (during text mode), when Xorg starts the video is displayed correctly.
I tried to start the PC in text mode only (runlevel 3) and when the booting sequence is about half done the monitor starts blanking and is gone completely.
If I connect to the pc via ssh and issue a init 5 to switch to runlevel 5 the video is shown ok and if I reissue a init 3 to go back to runlevel 3 the video is shown ok as well, seems that something is changed in the graphic board.
I’ve found that the problem arises only when the system boots in runlevel 3 or is switching from textmode to graphics(runlevel 5).
When the system is started in runlevel 3 and the monitor blanks, if I issue the command:
/usr/bin/nvidia-smi -L
the video is suddenly shown ok (I see Linux login) but after some seconds goes away again, and if I reissue the same command above the login turns back then goes away again.
I tried to put the board in Persistent mode ( /usr/bin/nvidia-smi -pm 1 ) but it didn’t work either issuing the nvidia-smi -L .
I’ve looked with the command: nvidia-smi -q and found that when I am in text only mode the attribute: Display Mode is set to Disabled
whereas when in runlevel 5 the Display Mode is set to Enabled
Is there a way to solve this problem? seems that when in text mode (runlevel 3) or in the way to switch to runlevel 5 the Graphic board seems to sleep and doesn’t provide the signal to the monitor and if I query the board with the nvidia-smi -L she wakes up for some seconds and then back again to sleep and the console is not displayed on the monitor.
Any help?
Best regards
nvidia-bug-report.log.gz (90.5 KB)