Nvidia Reflex Unreal Engine 5

Hello I have been trying to get nvidia reflex working for about a day now and my issue is that it doesnt seem to do anything no debug, cant tell if reflex is working which I imagine its not. I followed nvidias guide and my code is identical, https://www.youtube.com/watch?v=BihuOz_earw. I talked with nvidia support earlier so far I have re-installed my drivers with a clean install to remove any possible conflicts there, I have tried starting with no services basically running except the required to see if there was any conflicts and still it did not function as expected. When I load in my game it shows the debug text however it just sits at 0 constantly. My code, while simulating not sure if I should expect an indication its firing. Below is a merged image of my code/ the debug producing 0 I could only upload one image being new and all.

Oh and I have a 2080 super I have used reflex in multiple games without issue just cannot implement it into my own project for some reason. I even tried it inside a 100% fresh project specifically for testing reflex and I had no luck. Am I doing something wrong?

1 Like

Hello @andrewj0013 and welcome to the NIVIDIA developer forums!

Nice to see you using the Reflex SDK! I am sorry you are having trouble with it. It is still rather fresh off the press, especially since UE5 just came out, and we appreciate any issues or problems brought to our attention.

I am not an expert on this SDK, so I will try to get someone more informed to join the conversation.

You mentioned NVIDIA support, was that generic chat or phone support or do you have a Developer Relations representative for your development studio?


Thanks, the support I contacted was the live chat support I had a technician helping me at first believe his name was Sen. I do not have a developer relation representative myself I am an indie dev and have only been working on it for a year now. All solo/ indie I have been learning as much as I can as fast as I can. Sometimes coming across things above my scope.

Hi again, I wanted to give a quick update.

It seems that there were some changes both in UE5 and the Reflex SDK since the making of that video. While it does still work as expected in UE 4.72.2, it does not report correct values in the latest build of UE5, just as you are reporting.

Engineering is on the case and I will update here if I receive some news.


Hey any word on this yet? Havnt dug through reflex code much but figured its better to leave it to the engineers. Maybe possibly ue5.1?

Hi @andrewj0013 ! You were a bit faster than me. I just received word that the SDK owners released a new version on Github that should address this issue. This is now for UE 5.0.2.

I hope this solves the issues you are seeing!

Have you figured out the solution to this? I’m facing the same thing and it looks like it wasnt fixed or the uplugin is still outdated.
The solution that @MarkusHoHo provided wont work if your engine is downloaded from epic games launcher, you need to download the source code for the engine and build it which is not ideal solution.