Nvidia Riva "sudo bash riva_init.sh" error

Hello, I’m having a problem with initializing Nvidia Riva (The server side)
My operating system for the server is Ubuntu Server
Here’s the log:

ai@ai:~/riva/riva_quickstart_v2.14.0$ sudo bash riva_init.sh
Please enter API key for ngc.nvidia.com:
Logging into NGC docker registry if necessary…
Pulling required docker images if necessary…
Note: This may take some time, depending on the speed of your Internet connection.
Pulling Riva Speech Server images.
Image nvcr.io/nvidia/riva/riva-speech:2.14.0 exists. Skipping.
Image nvcr.io/nvidia/riva/riva-speech:2.14.0-servicemaker exists. Skipping.

Downloading models (RMIRs) from NGC…
Note: this may take some time, depending on the speed of your Internet connection.
To skip this process and use existing RMIRs set the location and corresponding flag in config.sh.
docker: Error response from daemon: failed to create task for container: failed to create shim task: OCI runtime create failed: runc create failed: unable to start container process: error during container init: error running hook #0: error running hook: exit status 1, stdout: , stderr: Auto-detected mode as ‘legacy’
nvidia-container-cli: initialization error: load library failed: libnvidia-ml.so.1: cannot open shared object file: no such file or directory: unknown.
Error in downloading models.

Fixed! I just had to run the

nvidia-smi
command and if there was an error, then it would give you this.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.