NVIDIA RTX Caustics Branch

Hi, I’ve been meaning to work with Caustics on Unreal Engine through NVIDIA RTX Caustics Branch, I’ve done every step and it should be up and running, but it’s not. The Editor opens up, the plugins are installed and on, and I can tell RTXGI is working, but the caustics aren’t. There no option to turn them on or off. I tried though commands, but nothing happend.

Am I missing something? I really want to make this work.

Hello there! Did you try one of the sample projects in that branch and what is the result? I listed them below.
Thank you.


I have the same issue. The 5.1 caustics branch builds and runs fine, I have downloaded the caustics samples and loaded them into the version of Unreal - but get no caustics. Using the shortcut for toggling caustics gives command not recognised in the log. This is with the latest drivers on a 4090. Also I don’t see the settings for caustics in the project editor windows.

@goca14hl did you ever solve your problem?

Hi @maxpalmer and welcome to the NVIDIA developer forums!

I wonder if @bach44 might be able to help. They just recently pointed out that we needed to update the Caustics branch and then was able to get it to run.

See Unable to compile the UE5.1 Caustics branch - #6 by bach44

1 Like