Nvidia sdhci sd card boot issue

jetpack 4.6
I flashed a custom image to emmc
sudo ./flash.sh --no-systemimg JN_NN mmcblk0p1

the device booted
after that i used rootOnNVMe-master.zip and performed the command copy-rootfs-ssd.sh
setup-service.sh
after creating a partition in disk of the device
when powercycled it boots up
and then when i run command reboot
it shows the image nvidia and shows logs of
a start job is running for docker application nvidia
sdhci :
mmcblk:error in transfering data

these are the logs that i was able to notice
and then lands on black screen
when i run ifconfig
it shows ip
but cant enter via ssh

help me out to get the boot correctly
please reach out for any further steps to be done

i can access ssh now…

What is your custom image?

You don’t provide any log so it’s hard to know what happened.
You should also know that this rootOnNVMe tool is not made by us.

please direct me
how to get logs

Get the serial console log here.

im not getting logs in minicom
image

Re-flash the device and repeat what you did earlier.
I really have no idea what you did exactly.

image
im getting echo
why im not getting logs?

i will try copying to sd card via etcher
should i put system.img or boot.img

Sorry, you should be doing this:

This one:
https://developer.nvidia.com/embedded/l4t/r32_release_v7.1/jp_4.6.1_b110_sd_card/jeston_nano/jetson-nano-jp461-sd-card-image.zip

where should the etcher be installed to perform these operations
in our device ?
or in our laptop ?
if it is in our laptop
should we connect device via usb or the sd card to sd card slot in lap?

On your host PC.

what about this ?

The latter one.


image

out of these could you help me which image needs to flashed into sd card

im using etcher instead of rootOnNVMe-master

I have no idea what you are trying to do now.

Aren’t you using this one?

actually we have our custom image/firmware which has been flashed into device
we need to boot from sd card

OK, wait.
So you have a module with eMMC, and a carrier board with SD card slot, and you are asking how you can flash and boot with the SD card?

yes thats it
since im new to nvidia , iwas not able to point out the exact querry
thank you in advance

Bootloader on Jetson Nano does not supporting loading kernel from the external SD card,
so you should still be using the rootOnNVMe tool. but change all paths in thay tool with /dev/nvme0n1p1 to /dev/mmcblk1p1.

ok
will let you know

can i know the difference with both these tools/applications
thank you