NVidia SDK Manager Not Flashing: Failed to bind partitions


I have a problem installing DRIVE OS 6.0.4 on my Drive Orin AGX.
I have followed the instructions, however the flash step fails.

This is the fail message in from the sdkmanager screen:
06:36:23 ERROR: Flash DRIVE OS - flash: command terminated with error
06:36:23 SUMMARY: Flash DRIVE OS - flash: First Error: Installation failed.

When I look into the log files, and grep for fail, i get this:
DRIVE_OS_6.0.4_SDK_Linux_replay.txt:2335:[ -e ${AURIX_PORT:-/dev/ttyACM1} ] || ( echo Failed to flash device: detected no board connected to host with USB cable. >&2 && false ) – I’m sure that I don’t have anything connected to the device and I also did reset the system.

All of the USB’s and LAN connected.

I’m adding here the logs and ~/.nvsdkm dirs.

nvsdkm.zip (608.1 KB)
SDKM_logs_DRIVE_OS_6.0.4_SDK_(rev._1)_Linux_for_DRIVE_AGX_Orin_DevKits_2022-10-25_06-32-38.zip (181.8 KB)


Your topic was posted in the wrong category. I am moving this to the DRIVE AGX Orin category for visibility.

1 Like

@NikolayChernuha I found the log snippet in your driveinstaller.log.

[2022-10-25 06:36:23,501 root DEBUG inforom_data_handler.py 109 6483] response on /dev/ttyACM1 = [b’version\r\n’, b’\r\n’, b’Unknown command: \xfe\xe6\xe6\x80\xfe\xe6\xe6\x80\xfe\xe6\xe6\x80~\r\n’, b’Shell>\r\n’, b’Shell>']
[2022-10-25 06:36:23,502 root INFO runner.py 37 6483] Failed to bind partitions!
[2022-10-25 06:36:23,502 root DEBUG runner.py 39 6483] Error on line 910
[2022-10-25 06:36:23,502 root DEBUG runner.py 40 6483] Exception info: Exception Type <class ‘module.errors.FailedToBindPartitionsError’>, Traceback <traceback object at 0x7fa38b9888c8>
[2022-10-25 06:36:23,502 root INFO runner.py 45 6483] driveinstaller cannot continue! Check the log file for details: /home/nikolaychernuha/.nvsdkm/driveinstaller.log
[2022-10-25 06:36:23,503 root DEBUG runner.py 62 6483] Cleaning up…
[2022-10-25 06:36:23,504 root DEBUG utilities.py 137 6483] Deleting temporary directories…
[2022-10-25 06:36:23,504 root DEBUG runner.py 64 6483] Closing the log file.
[2022-10-25 06:55:52,410 root DEBUG log_setup.py 68 8766] Logging to file: /home/nikolaychernuha/.nvsdkm/driveinstaller.log

It’s similar to Flashing Failed - Drive OS. Please see if either post of the topic below helps on your side.
Flashing Failed - Drive OS - #12 by VickNV
Flashing Failed - Drive OS - #14 by JaxSpar

I have successfully finished the installation. I had a missing package and had to run the system to recovery mode.
So basically the problem is solved.

Thanks for letting us know.

Did you install it with SDK Manager? Why did you put the system into recovery mode manually?

I installed the Drive OS with SDK.
I had to put the system to recovery mode because in other hand the installation was failed. As soon as I put the system to recovery mode, everything installed smoothly.

Good to know. May I know how you put the system into recovery mode? Right before clicking the button in sdkmanager to flash, right?

Well, I’ll explain the behavior:
I have connected all USB cable to my host pc and did lsusb, I saw only 1 port, which was the debug port.
I have tried to install the device thru sdkmanager, but after 14% it failed, so it was clear that I don’t have communication for some reason.
Then I decided to boot the system to recovery mode, by turning it off and the holding the recovery button and turning on the device, then I saw another device in lsusb, which also prompted me to choose a device in step 1 in sdkmanager and I got installation finished in step 4.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.