(nvidia-settings:3510): GLib-GObject-CRITICAL **: 21:06:40.170: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

I am using a 5.15.32-1-MANJARO Linux and I doubt that my Nvidia GeForce GTX 1050 Ti Mobile drivers are corrupt/not working.

“nvidia-settings” in Terminal results in

  • (nvidia-settings:3896): GLib-GObject-CRITICAL **: 21:10:01.297: g_object_unref: assertion ‘G_IS_OBJECT (object)’ failed

generated bug report:
nvidia-bug-report.log.gz (260.2 KB)

Can someone help me fix this!
I am currently using the “video-hybrid-intel-nvidia-prime”, with Intel being the primary display.

I tried switching it to Nvidia but it just ended up crashing my system and leading to a black screen.

Looks fine, the nvidia gpu is in offload mode. Use “prime-run” to start applications on it.
How did you try to “switch to Nvidia”?

I am like very very new to Linux so just followed a bunch of tutorials but none of them worked.
I tried “prime-run” but I don’t think anything is happening!

I don’t know if this will help but when I run “optimus-manager --status”
I get this:
Current GPU mode : integrated
GPU mode requested for next login : no change
GPU at startup : integrated
Temporary config path: no


and observe if nvidia-smi shows the process.

Yes, it is showing the process. My sensors tab also finally recognized my Nvidia GPU being used.

prime-run glxgears
should do the same.

Yes, it is doing the same, thank you very much.
I guess now I do the same with any program that I want my Nvidia GPU to run with.

However, isn’t there an alternative to run the Nvidia graphics like always? I realize that it might affect my battery life but I still wanted to know.


Thank you for your help :)