nvidia-settings does not open after installing Proprietary Drivers on Fedora 26.

[root@devil ~]# nvidia-settings
No protocol specified

** (nvidia-settings:3320): WARNING **: Could not open X display

ERROR: Unable to find display on any available system

can anyone help me with this problem?
I tried more than 3 times but still not working
nvidia-bug-report.log.gz (51.6 KB)

My laptop is HP Pavilion-p077tx, with core i5, 8GB RAM, 1TB HDD, 2GB Nvidia 840M Graphics.
if possible please let me know how to install the drivers exactly

Please run nvidia-bug-report.sh and attach created tar.gz file to your post.
Other than that, nvidia-settings has to be run as user that owns the xserver, otherwise DSIPLAY and XAUTHORITY has to be set.

Didn’t see your PM before.
You have an Optimus Laptop, this takes some more to set up, i.e. PRIME output.
How did you install the nvidia driver, from repo or using the .run installer?
Generally, you will have to blacklist the nouveau driver, that’s currently blocking the nvidia driver.
Then, you will have to create a special xorg.conf and set up your DE to run a script on start. See:
https://devtalk.nvidia.com/default/topic/1022670/linux/official-driver-384-59-with-geforce-1050m-doesn-t-work-on-opensuse-tumbleweed-kde/post/5203910/#5203910

Hey Generix,
I used .run installer for linux from Official NVIDIA website.
I refered to this Guide https://www.if-not-true-then-false.com/2015/fedora-nvidia-guide/
And yes I disabled the nouveau driver.

Blacklisting didn’t work, nouveau gets loaded anyway according to the logs. Check your blacklist.conf.

Sorry Generix,
My whole laptop got wiped due to making changes to MBR and GPT manually.
Now I’m again dual booting my WINDOWS 10 & FEDORA 26.
When I get it done, I’ll see the blacklist.conf file and see if NVIDIA DRIVERS WORKS and respond you.