nvidia-settings only able to communicate with GPU0 on F27 running kernel version 4.14.6-300. Works on Centos7 running kernel version 3.10.0-693

I’ve been using a script to set values for all GPUs in a machine which has been successful for driver version up through 384.98.

After upgrade to v387.34, the settings only affect the first device. Other cards silently ignore the command.

Trying with the following:

sudo /usr/bin/xinit /usr/bin/nvidia-settings -c :0 -a [gpu:1]/GPUMemoryTransferRateOffset[3]=500

gpu:0 works, all others ignore the command. This is true of any attribute setting sent to cards other than GPU0.

removed: not relevant

After reverting the F27 system back to Nvidia driver version 384.98, I see the problem persists. This appears to be some difference between the F27 system and the Centos7 systems. Same hardware works fine on the Centos7 system

More detail to demonstrate what I am seeing and to reflect Title change:

On Centos7:

$ uname -a
Linux tincup 3.10.0-693.11.1.el7.x86_64 #1 SMP Mon Dec 4 23:52:40 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

$ sudo /bin/xinit /bin/nvidia-settings -a "GPUGraphicsClockOffset[3]=120" -- :0 -once

X.Org X Server 1.19.3
Release Date: 2017-03-15
X Protocol Version 11, Revision 0
Build Operating System:  3.10.0-514.16.1.el7.x86_64
Current Operating System: Linux 3.10.0-693.11.1.el7.x86_64 #1 SMP Mon Dec 4 23:52:40 UTC 2017 x86_64
Kernel command line: BOOT_IMAGE=/vmlinuz-3.10.0-693.11.1.el7.x86_64 root=UUID=4d74b023-57d8-4e50-b4b9-b928db1b77cc ro rootflags=subvol=root crashkernel=auto rhgb quiet LANG=en_US.UTF-8 nouveau.modeset=0 rd.driver.blacklist=nouveau
Build Date: 05 August 2017  06:19:43AM
Build ID: xorg-x11-server 1.19.3-11.el7
Current version of pixman: 0.34.0
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Dec 21 08:18:39 2017
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"

  Attribute 'GPUGraphicsClockOffset' (localhost:0.0) assigned value 120.
  Attribute 'GPUGraphicsClockOffset' (localhost:0.1) assigned value 120.
  Attribute 'GPUGraphicsClockOffset' (localhost:0[gpu:0]) assigned value 120.
  Attribute 'GPUGraphicsClockOffset' (localhost:0[gpu:1]) assigned value 120.

/bin/xinit: connection to X server lost

waiting for X server to shut down ..(II) Server terminated successfully (0). Closing log file.

On F27:

$ uname -a
Linux tincup 4.14.6-300.fc27.x86_64 #1 SMP Thu Dec 14 15:31:24 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

$ sudo /bin/xinit /bin/nvidia-settings -a "GPUGraphicsClockOffset[3]=120" -- :0 -once

X.Org X Server 1.19.5
Release Date: 2017-10-12
X Protocol Version 11, Revision 0
Build Operating System:  4.12.9-300.fc26.x86_64
Current Operating System: Linux tincup 4.14.6-300.fc27.x86_64 #1 SMP Thu Dec 14 15:31:24 UTC 2017 x86_64
Kernel command line: BOOT_IMAGE=/vmlinuz-4.14.6-300.fc27.x86_64 root=UUID=c4c53566-cb74-496f-a7a5-885f18df9b55 ro rhgb quiet LANG=en_US.UTF-8 rd.driver.blacklist=nouveau
Build Date: 12 October 2017  07:35:27PM
Build ID: xorg-x11-server 1.19.5-1.fc27
Current version of pixman: 0.34.0
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Dec 21 08:25:33 2017
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"

  Attribute 'GPUGraphicsClockOffset' (localhost:0.0) assigned value 120.
  Attribute 'GPUGraphicsClockOffset' (localhost:0[gpu:0]) assigned value 120.

/bin/xinit: connection to X server lost

waiting for X server to shut down (II) Server terminated successfully (0). Closing log file.

Same hardware running different OS. Behavior is the same whether I am running on driver version 384.98 or 387.x

On F27, command to query the gpus sees both gpus.

$ sudo /usr/bin/xinit /usr/bin/nvidia-settings -q gpus -- :0 -once

X.Org X Server 1.19.5
Release Date: 2017-10-12
X Protocol Version 11, Revision 0
Build Operating System:  4.12.9-300.fc26.x86_64
Current Operating System: Linux tincup 4.14.6-300.fc27.x86_64 #1 SMP Thu Dec 14 15:31:24 UTC 2017 x86_64
Kernel command line: BOOT_IMAGE=/vmlinuz-4.14.6-300.fc27.x86_64 root=UUID=c4c53566-cb74-496f-a7a5-885f18df9b55 ro rhgb quiet LANG=en_US.UTF-8 rd.driver.blacklist=nouveau
Build Date: 12 October 2017  07:35:27PM
Build ID: xorg-x11-server 1.19.5-1.fc27
Current version of pixman: 0.34.0
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Dec 21 08:48:20 2017
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"

2 GPUs on victor:0

    [0] tincup:0[gpu:0] (GeForce GTX 1080 Ti)

      Has the following names:
        GPU-0
        GPU-294a3cf8-c4c8-0a0b-d710-3dce0c1b0d84

    [1] tincup:0[gpu:1] (GeForce GTX 1080 Ti)

      Has the following names:
        GPU-1
        GPU-d467fa28-4d46-d1fb-a433-1187d0665e0d

/usr/bin/xinit: connection to X server lost

waiting for X server to shut down (II) Server terminated successfully (0). Closing log file.