nvidia-settings -q all crash

This crash kills the current X session dropping you to the session manager.

Steps to reproduce:

  1. startx
  2. open a terminal
  3. run nvidia-settings -q all -> you can see a bit of info is displayed but then your are at the DM ( LightDM in my case )

LE: And you can see an nvidia-bug-report run just after such a crash attached here https://devtalk.nvidia.com/default/topic/529521/linux/lasting-reproducible-frame-rate-drop-to-7fps-on-gtx-560-ti-313-18-driver/post/4212614/#4212614

I’ll re-attach the strace log as soon as possible since I now see it just disappeared or something.

nvidia-settings-q-all_337.19.txt.gz (63.9 KB)

Earlier driver worked for you ?

Yep, all worked great, this one flakes out.

With driver 337.19 and nvidia-settings-334.21 the problem does not occur.
So i would say, the problem is in nvidia-settings itself.

I can also attest that this happens on my machine with nvidia-settings version 337.19. Xorg crashes and I get back to my display manager as the OP mentioned. Querying individual attributes seems to work correctly.

As towo mentioned, a manually compiled version of nvidia-settings-334.21 from the source here does not exhibit this issue. Maybe it’s related to the addition of the new overclocking attributes that are available in the 337 version.

I reproduced this problem and filed bug 1515356.