nvidia-smi can't find a 2080Ti on ubuntu 18

Sorry if this is a duplicated post. I tried searching for a similar issue but could not find anything.

I have a machine with a 1080 Ti and a 2080 Ti that was working fine until an upgrade to ubuntu 18. After the update nvidia-smi finds only the 1080.

I have NVIDIA-Linux-x86_64-440.36 installed.

However, lspci finds the 2080:

41:00.0 VGA compatible controller: NVIDIA Corporation TU102 [GeForce RTX 2080 Ti] (rev a1) (prog-if 00 [VGA controller])
Subsystem: ASUSTeK Computer Inc. Device 8675
Flags: bus master, fast devsel, latency 0, IRQ 69
Memory at 9c000000 (32-bit, non-prefetchable)
Memory at 80000000 (64-bit, prefetchable)
Memory at 90000000 (64-bit, prefetchable)
I/O ports at 3000
[virtual] Expansion ROM at 000c0000 [disabled]
Kernel driver in use: nvidia
Kernel modules: nvidiafb, nouveau, nvidia_drm, nvidia

dmesg says the following:

NVRM: GPU 0000:41:00.0: RmInitAdapter failed! (0x26:0xffff:1227)
NVRM: GPU 0000:41:00.0: rm_init_adapter failed, device minor number 1

Has anyone experienced a similar problem and could fix it?

Or is this just a hw failure that coincided with the update?

HW issue. Please try reseating the card in its slot. If it still doesn’t work, RMA if still under warranty.