Nvidia-smi got no devices were found after nvidia-driver-525 installation on ubuntu 20.04 running with Esxi8.0 passthrough GTX1650

Thanks for your reply!
After doing some search, I rebuilt Ubuntu server 22.04.2 LTS VM and install nvidia drivers following by this.
Unfortunately,I got ‘No devices were found’ again. :(

dmesg | grep NV
output:
[ 0.000000] BIOS-e820: [mem 0x0000000000000000-0x0000000000000fff] ACPI NVS
[ 0.000000] BIOS-e820: [mem 0x000000000fbfb000-0x000000000fbfefff] ACPI NVS
[ 0.000000] reserve setup_data: [mem 0x0000000000000000-0x0000000000000fff] ACPI NVS
[ 0.000000] reserve setup_data: [mem 0x000000000fbfb000-0x000000000fbfefff] ACPI NVS
[ 0.121946] ACPI: PM: Registering ACPI NVS region [mem 0x00000000-0x00000fff] (4096 bytes)
[ 0.121946] ACPI: PM: Registering ACPI NVS region [mem 0x0fbfb000-0x0fbfefff] (16384 bytes)
[ 0.125703] ACPI: Added _OSI(Linux-Lenovo-NV-HDMI-Audio)
[ 7.045276] input: HDA NVidia HDMI/DP,pcm=3 as /devices/pci0000:02/0000:02:05.1/sound/card0/input6
[ 7.045652] input: HDA NVidia HDMI/DP,pcm=7 as /devices/pci0000:02/0000:02:05.1/sound/card0/input7
[ 7.045726] input: HDA NVidia HDMI/DP,pcm=8 as /devices/pci0000:02/0000:02:05.1/sound/card0/input8
[ 7.047872] input: HDA NVidia HDMI/DP,pcm=9 as /devices/pci0000:02/0000:02:05.1/sound/card0/input9
[ 7.047950] input: HDA NVidia HDMI/DP,pcm=10 as /devices/pci0000:02/0000:02:05.1/sound/card0/input10
[ 7.048024] input: HDA NVidia HDMI/DP,pcm=11 as /devices/pci0000:02/0000:02:05.1/sound/card0/input11
[ 598.548112] NVRM: loading NVIDIA UNIX Open Kernel Module for x86_64 525.89.02 Release Build (dvs-builder@U16-F11-34-6) Wed Feb 1 23:19:51 UTC 2023
[ 598.576564] nvidia-modeset: Loading NVIDIA UNIX Open Kernel Mode Setting Driver for x86_64 525.89.02 Release Build (dvs-builder@U16-F11-34-6) Wed Feb 1 23:10:24 UTC 2023
[ 612.396778] NVRM: loading NVIDIA UNIX Open Kernel Module for x86_64 525.89.02 Release Build (dvs-builder@U16-F11-34-6) Wed Feb 1 23:19:51 UTC 2023
[ 612.402809] nvidia-modeset: Loading NVIDIA UNIX Open Kernel Mode Setting Driver for x86_64 525.89.02 Release Build (dvs-builder@U16-F11-34-6) Wed Feb 1 23:10:24 UTC 2023
[ 801.049919] NVRM tmrSetCurrentTime_GV100: ERROR: Write to PTIMER attempted even though Level 0 PLM is disabled.
[ 801.049921] NVRM nvAssertFailedNoLog: Assertion failed: 0 @ timer_gv100.c:80
[ 805.048201] NVRM _threadNodeCheckTimeout: _threadNodeCheckTimeout: currentTime: 3d09757cbdff00 >= 3d09757cbdff00
[ 805.048204] NVRM _threadNodeCheckTimeout: _threadNodeCheckTimeout: Timeout was set to: 4000 msecs!
[ 805.048207] NVRM kflcnWaitForHalt_TU102: Timeout waiting for Falcon to halt
[ 805.048208] NVRM s_executeFwsec_TU102: failed to execute FWSEC cmd 0x15: status 0x65
[ 805.048223] NVRM nvAssertOkFailedNoLog: Assertion failed: Call timed out [NV_ERR_TIMEOUT] (0x00000065) returned from kgspExecuteFwsecFrts_HAL(pGpu, pKernelGsp, pKernelGsp->pFwsecUcode, pKernelGsp->pWprMeta->frtsOffset) @ kernel_gsp_tu102.c:363
[ 805.048226] NVRM kgspInitRm_IMPL: cannot bootstrap riscv/gsp: 0x65
[ 805.048229] NVRM RmInitAdapter: Cannot initialize GSP firmware RM
[ 805.049722] NVRM: GPU 0000:02:05.0: RmInitAdapter failed! (0x62:0x65:1615)
[ 805.050481] NVRM: GPU 0000:02:05.0: rm_init_adapter failed, device minor number 0
[ 805.183959] NVRM tmrSetCurrentTime_GV100: ERROR: Write to PTIMER attempted even though Level 0 PLM is disabled.
[ 805.183961] NVRM nvAssertFailedNoLog: Assertion failed: 0 @ timer_gv100.c:80
[ 805.271495] NVRM s_executeBooterUcode_TU102: Booter failed with non-zero error code: 0xff
[ 805.271497] NVRM kgspExecuteBooterUnloadIfNeeded_TU102: failed to execute Booter Unload: 0xffff
[ 809.180192] NVRM _threadNodeCheckTimeout: _threadNodeCheckTimeout: currentTime: 3d097673075000 >= 3d097673075000
[ 809.180196] NVRM _threadNodeCheckTimeout: _threadNodeCheckTimeout: Timeout was set to: 4000 msecs!
[ 809.180211] NVRM kflcnWaitForHalt_TU102: Timeout waiting for Falcon to halt
[ 809.180213] NVRM s_executeFwsec_TU102: failed to execute FWSEC cmd 0x15: status 0x65
[ 809.180215] NVRM nvAssertOkFailedNoLog: Assertion failed: Call timed out [NV_ERR_TIMEOUT] (0x00000065) returned from kgspExecuteFwsecFrts_HAL(pGpu, pKernelGsp, pKernelGsp->pFwsecUcode, pKernelGsp->pWprMeta->frtsOffset) @ kernel_gsp_tu102.c:363
[ 809.180231] NVRM kgspInitRm_IMPL: cannot bootstrap riscv/gsp: 0x65
[ 809.180235] NVRM RmInitAdapter: Cannot initialize GSP firmware RM
[ 809.181631] NVRM: GPU 0000:02:05.0: RmInitAdapter failed! (0x62:0x65:1615)
[ 809.182382] NVRM: GPU 0000:02:05.0: rm_init_adapter failed, device minor number 0
[ 847.591908] NVRM tmrSetCurrentTime_GV100: ERROR: Write to PTIMER attempted even though Level 0 PLM is disabled.
[ 847.591913] NVRM nvAssertFailedNoLog: Assertion failed: 0 @ timer_gv100.c:80
[ 847.678182] NVRM s_executeBooterUcode_TU102: Booter failed with non-zero error code: 0xff
[ 847.678184] NVRM kgspExecuteBooterUnloadIfNeeded_TU102: failed to execute Booter Unload: 0xffff
[ 851.588217] NVRM _threadNodeCheckTimeout: _threadNodeCheckTimeout: currentTime: 3d098052be0a00 >= 3d098052be0a00
[ 851.588220] NVRM _threadNodeCheckTimeout: _threadNodeCheckTimeout: Timeout was set to: 4000 msecs!
[ 851.588235] NVRM kflcnWaitForHalt_TU102: Timeout waiting for Falcon to halt
[ 851.588237] NVRM s_executeFwsec_TU102: failed to execute FWSEC cmd 0x15: status 0x65
[ 851.588239] NVRM nvAssertOkFailedNoLog: Assertion failed: Call timed out [NV_ERR_TIMEOUT] (0x00000065) returned from kgspExecuteFwsecFrts_HAL(pGpu, pKernelGsp, pKernelGsp->pFwsecUcode, pKernelGsp->pWprMeta->frtsOffset) @ kernel_gsp_tu102.c:363

New bug report attached.
nvidia-bug-report.log.gz (64.4 KB)