Nvidia-smi " No running processes found "

Hi all, I think I did something wrong when I tried to install Turbovnc and VirtualGL.

Right now when I run the nvidia-smi command

I get the message “No Running Processes found”.

Also the following command only gives the following output.

lsmod | grep nvidia

nvidia 40792064 125
drm 585728 5 drm_kms_helper,nvidia,mgag200

glxinfo | head
name of display: localhost:15.0
display: localhost:15 screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4
server glx extensions:
GLX_ARB_create_context, GLX_ARB_create_context_no_error,
GLX_ARB_create_context_profile, GLX_ARB_fbconfig_float,
GLX_ARB_framebuffer_sRGB, GLX_ARB_multisample,
GLX_EXT_create_context_es2_profile, GLX_EXT_create_context_es_profile,

My goal was just to use nvidian 3d acceleration when connected to my Redhat 8.6 Linux machine with turbovnc. What is the simplest way to fix the above error and message and use 3d accelerator and opengl when connected with vnc?

Since there’s also the mgag200 driver loaded, the Xserver is probably running on that. Please either disable the server graphics in bios or create an xorg.conf so the Xserver is running on the nvidia gpu. Afterwards, install VirtualGL, after that, running vglrun glxinfo -B in a turbovnc session should output “Nvidia”.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.