nvidia-smi not fully supported on GTX 1060

My 1060’s obey power limit perfectly. They don’t change P-State and OC, though. So, I guess, it also depends on the VROM.

Similar error trying to OC this:

ubuntu server 16.10
Nvidia v375.66
installed lightdm

$nvidia-smi -i 0 -ac 4004,900
Setting applications clocks is not supported for GPU 0000:01:00.0.
Treating as warning and moving on.
All done.

This card was previously installed in w10 rig & OC with no problem at all, so it’s no a firmware/HW issue. I believe problem is a poorly developed linux drivers (I’m not blaming dev capabilities, I assume lack of enough resources)

Same issue.

Linux DESKTOP-4EIB8GR 4.8.0-58-generic #63~16.04.1-Ubuntu SMP Mon Jun 26 18:08:51 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
Driver Version                      : 381.22
VBIOS Version                   :
# dpkg -l |grep -i nvidia
ii  bbswitch-dkms                         0.8-3ubuntu1                               amd64        Interface for toggling the power on NVIDIA Optimus video cards
ii  libcuda1-381                          381.22-0ubuntu0~gpu16.04.2                 amd64        NVIDIA CUDA runtime library
ii  nvidia-381                            381.22-0ubuntu0~gpu16.04.2                 amd64        NVIDIA binary driver - version 381.22
ii  nvidia-opencl-icd-381                 381.22-0ubuntu0~gpu16.04.2                 amd64        NVIDIA OpenCL ICD
ii  nvidia-prime                          0.8.2                                      amd64        Tools to enable NVIDIA's Prime
ii  nvidia-settings                       381.22-0ubuntu0~gpu16.04.1                 amd64        Tool for configuring the NVIDIA graphics driver

Same issue here as well for cards GTX 1070 and P106-100. I tried on different motherboards (asrock and biostar)

Running driver 381.22 on Gentoo, tested with 381.22-r1 and 378.13 but no success.

I can query and set the power limit.

This problem is so annoying!

With 381.22 I’ve been able to get my 1060s to overclock and take power limits on down to 60w. Don’t bother trying to set application clocks.

For a multi-cpu system, two in my case:

#> nvidia-xconfig --enable-all-gpus --cool-bits=12

cool-bits=12 enables overclocking and fan control (8+4) which is what I use. No need to modify xorg.conf directly.

Reboot – just restarting X doesn’t usually work for me.

At this point Powermizer should allow offsets. I had no luck saving and modifying the nvidia-settings config file. It would remove my changes with each reload. Had to script it.


sudo nvidia-smi -pm 1
sudo nvidia-smi -pl 75

nvidia-settings -a [gpu:0]/GPUGraphicsClockOffset[3]=200
nvidia-settings -a [gpu:0]/GPUMemoryTransferRateOffset[3]=1200

nvidia-settings -a [gpu:1]/GPUGraphicsClockOffset[3]=200
nvidia-settings -a [gpu:1]/GPUMemoryTransferRateOffset[3]=1000
nvidia-settings -a [gpu:1]/GPUFanControlState=1
nvidia-settings -a [fan:1]/GPUTargetFanSpeed=80

The fan control is just to keep the inside card from exceeding 70C in my rig. The [3] on the offsets sets everything for performance level 3. That’s nvidia-settings performance level, not the P-state. nvidia-settings will still say you’re in 2. Ignore it.

You can now start nvidia-settings to confirm the changes took.

If this all still doesn’t work, then I dunno. Works for me.

theapc, we are discussing server distro Ubuntu here. In server distro nvidia-settings utility is not available.

I use 17.04-server. It’s just in the nvidia-settings package.

For me nvidia-settings does not work without xorg installed, at least in 16.04 LTS. And to get xorg installed and running I need to do “apt-get install ubuntu-desktop”.

So, you are saying, that it’s enough to download the server 17.04 distro, install nvidia drivers (“apt-get install nvidia-381”), and nvidia-settings will be usable for overclocking and fan control?

No clue. I have X installed. Tho I’m sure there’s ways around it. Or just install X and disable/ignore it.

Well, we here are exactly looking for ways around it. And, afaik, server distro does not include X.

Don’t server and desktop use the same repositories? I just installed gdm3 and the rest took care of itself.

But I imagine you could build nvidia-settings from source and just fill in the dependencies as they come up.

And then just use this instead of cool-bits

nvidia-settings -a '[gpu:0]/GPUPowerMizerMode=1'

imho the best would be to add the overclocking/p-state features from nvidia-settings to nvidia-smi, so you don’t have the dependency to a x server…

Edit: anyone tried the new 384.47 beta drivers yet? do they change anything?

npl3, exactly. It looks, however, clock/fan control is somehow linked to video signal generation. Remember, in Windows you can’t control fan/clocks unless you have a monitor/monitor emu attached? There must be something behind that.


The problem with the power limit also happens with the PNY GTX 1060 6G.

I tried the 384.47 driver but it does not change anything, the power limit still doesn’t work.

Nvidia-smi tool can be used for Oveclocking only on Tesla & Quadro

On consumer gpu can not overclock Nvidia without nvidia-setting in xorg.

Nvidia-smi was ment lock on lower freq and will not give you overclock, for this purpose there is Powermizer with coolbits.So in basic with server edition you can not do it.

TDP limit problem happen only with ,multi GPU. If do NOT have one monitor per card tdp on first with go over limit. It is not problem in card it is driver problem.

I solve it by adding

nvidia-xconfig --allow-empty-initial-configuration

This will continue to load xorg if none of monitor detected on GPU. Maybe i am wrong but ony this worked at my rig.As i wrote on another thread, this is somekind of BUG ,nvidia-smi should not be depended on nvidia-settings. After load of OS i have another problem in xorg, but is will open my thread.

And yes, you can check clocks:

nvidia-smi -q

Search for Max clock.

I have gotten myself some Palit GTX 1060’s. And they have this problem (if one could call it a problem) that they do not exactly obey the power limit. :) When set to 80 Watts, they consume 90-91, when set to 90, they dance around 100.

Probably it’s how their VBIOS works.

I have gigabyte 1060 g1 rev 2.0 and nvidia-smi doesn’t support to change clock; but wattage by nvidia-smi -pl is supported and it’s obey it. I run it headless and overclock via nvidia-settings.
I don’t think it is only 1060, maybe all pascal GPU are affected.

Hi All ,
I’ve installed 16.04 Server version for lite OS size.
Just Simple X server is installed.

So, If I run nvidia-settings , it needs GTK library. and didn’t worked!

I also want to control with nvidia-smi -ac xxxx,xxxx .
But, Above described and I’ve also errors.

Is there any tweak or manual patch on kernel module control or other way to control clock in command line?

Thanks in advance for your helps.

Same problem exists on the p106-100s.

Is this working??
setting coolbits to 31