Nvidia-smi not working after conda installation on ubuntu 22.04

I made a fresh installation with
conda install pytorch torchvision torchaudio pytorch-cuda=11.7 -c pytorch-nightly -c nvidia

I got torch.cuda.is_available()

Trying to debug
command not known

As I saw in cuda 11.7 relase note on my computer
NVIDIA Linux Driver 520.43

I tried
sudo apt install nvidia-utils-520
I got recommanded package libnvidia-compute-525 nvidia-utils-520 nvidia-utils-525

NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

As I saw in other question that seems to be usefull
dpkg -l |grep nvidia
ii libnvidia-compute-525:amd64 525.60.11-0ubuntu0.22.04.1 amd64 NVIDIA libcompute package
ii nvidia-utils-520:amd64 525.60.11-0ubuntu0.22.04.1 amd64 Transitional package for nvidia-utils-525
ii nvidia-utils-525 525.60.11-0ubuntu0.22.04.1 amd64 NVIDIA driver support binaries

Any help appreciated

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

Thanks for your help, but problem seems to be solved after installing nvidia-drivers with
parameters >>> about >>> software and update >>> additional drivers

I thought that installation of cudatoolkit with conda bring nvidia drivers but it seems not to be the case

Your linux driver is not compatible with cuda toolkit you are using as 520.x or above is used for cuda toolkit 12. Consider lower version of driver 510.x or driver version of (495 or 470) to work with it.

I run torch.cuda.is_available() and got True and it seems to work properly.
I keep in mind your advice and will apply it if I meet any problem