Nvidia-smi “NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure …”

I was trying to set up the required packages to install deepstream and graph composer in my new HP notebook, which comes with a 3080 GPU. I was able to successfully install CUDA 11.4 but I’m having trouble with the driver 470.63.01 required.

Output when running nvidia-smi:
NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

I think the problem may be related to the key generation part while installing the driver, or something related to the kernel version of my system.

I’ve seen many similar problems in the forums related to this issue, but since I’ve tried many solutions and didn’t seem to work I decided to post my own question on the forum.
I’m running Ubuntu 18.04.6 LTS. The drivers have been installed with sudo apt install nvidia-driver-470’, and before that with the .run file provided by NVIDIA DRIVERS Linux x64 (AMD64/EM64T) Display Driver link.
In the terminal window nvidia-smi outputs the error in the title, and by running :

jose@TKEICPC:~$ sudo prime-select nvidia
Info: the nvidia profile is already set

Here’s the output for my pc hardware:
jose@TKEICPC:~$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Device 9a60 (rev 01)
01:00.0 VGA compatible controller: NVIDIA Corporation Device 249c (rev a1)

I haven’t disabled secure boot due to the fact that this pc is running a dual boot set up, with a partition for the Ubuntu LTS and another for a windows 11 OS.
Notice that I have attached the nvidia bug report file.

Thanks in advance.
nvidia-bug-report.log.gz (129.1 KB)

With secure boot enabled, you will have to set up module signing, otherwise the nvidia driver won’t load.
You can either use update-secureboot-policy or reinstall Ubuntu and choose the option “Install third-party Software” on install to achieve that.

1 Like

Thank you for your answer, as soon as I have set up Ubuntu with the third-party software option I’ll let you know if it works.

I have reinstalled the Ubuntu OS in a separated SSD, registered with a MOK and the nvidia drivers seem to appear now in the software & updates app.

I used this to graphicaly install the nvidia drivers version 470, the problem is that once I reboot the system I get the /dev/sdb1: clean, X/X files, Y/Y blocks message and can’t boot into the Ubuntu GUI.

I’ve tried the solutions provided by you in this post but it doesn’t seem to work:

  • delete /etc/X11/xorg.conf
  • make sure nvidia-prime is installed (sudo apt install --reinstall nvidia-prime)
  • switch to nvidia (sudo prime-select nvidia)
  • remove stray blacklist files (sudo rm /lib/modprobe.d/blacklist-nvidia.conf /etc/modprobe.d/blacklist-nvidia.conf)
  • update the initrd (sudo update-initramfs -u)
  • reboot

The good news is that at least now the drivers are working correctly:

jose@TKEICPC:~$ nvidia-smi
Wed Dec 29 09:43:15 2021
±----------------------------------------------------------------------------+
| NVIDIA-SMI 470.86 Driver Version: 470.86 CUDA Version: 11.4 |
|-------------------------------±---------------------±---------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
| | | MIG M. |
|===============================+======================+======================|
| 0 NVIDIA GeForce … Off | 00000000:01:00.0 Off | N/A |
| N/A 39C P8 9W / N/A | 17MiB / 16125MiB | 0% Default |
| | | N/A |
±------------------------------±---------------------±---------------------+

±----------------------------------------------------------------------------+
| Processes: |
| GPU GI CI PID Type Process name GPU Memory |
| ID ID Usage |
|=============================================================================|
| 0 N/A N/A 1311 G /usr/lib/xorg/Xorg 7MiB |
| 0 N/A N/A 1386 G /usr/bin/gnome-shell 8MiB |
±----------------------------------------------------------------------------+

I’m adding the bug report file as well.
nvidia-bug-report.log.gz (307.3 KB)

Now that’s a bigger problem. The kernel that comes with 18.04 is too old to support your intel igpu which is driving the internal screen. Before the nvidia gpu came alive, Xorg used the efifb as fallback.
While it’s no problem installing a newer kernel, this won’t work with secure boot enabled since it isn’t signed. So you would have to sign the kernel and modules by yourself or rather upgrade to 20.04, which has a 5.11 kernel that works. Might also be possible to use the signed kernel of 20.04 but don’t ask me how that would work.

First of all thanks for your quick reply.

Second: If I update to Ubuntu 20.04 can I use the Deepstream SDK and graph composer? Because in the quickstart guide the recommended OS is Ubuntu 16.04/18.04 if I remember correctly.

Should work, I wouldn’t know why not. for additional downloads, you can most often simply replace “1804” with “2004” in the package name to get the download for 20.04.

1 Like

Hi, in the end I had to reflash the entire SSD with an Ubuntu 20.04.3 LTS version.

Following your advice about third party software this time I was able to successfully install the nvidia drivers.

Just wanted to point out something:

  • If you try to install the drivers version 495, for cuda 11.5, install cuda 11.5 and then try to install tensorrt (either 8.2 GA/8.2GA update 1 or 8.2 EA) there’s an incompatibility issue with libinfer. And by the way why does the debian file have to be automatically for cuda 11.4, it does not make much sense to me when u advertise that is compatible with cuda 11.5?

I’d indicate that currently tensorrt does NOT support cuda 11.5, as well as not recommending to install Ubuntu 18.04 because of issues with kernels and newer GPU models.

Deepstream is compatible with this ubuntu version as you previously said, so I think maybe you should update your QuickStart guide.

Outdated recommendation

Thank you for your help with my issues, it was really helpful.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.