Nvidia-smi outputs "no devices were found"

Hi, I’m trying to install nvidia driver but nvidia-smi keeps outputting “no drivers were found” when other things such as nvidia-setting or systemctl status nvidia-persistenced.service works. I’ve installed through CLI (method 2 in this post) and I’ve tried 535, 535-server, 525, 470, and 390 (but report attached is 470).

I’ve tried this as well and it didn’t solve the issue.

Any advice please?

nvidia-bug-report.log.gz (243.4 KB)

Hi @chris.lee2 ,

Did you find any solution I am also facing a driver installation issue. after installing the driver while installing Cuda machine OS got corrupted

As for the 470 and the 535 version of the driver, it fails to initialize the card.
That makes me think, that it may be defective.

I would install windows to check. If the windows device manager shows an error I would consider it as a verified hardware error.

@manojkumarhr @Mart I was told from the seller of the computer that their system is not compatible with nvidia driver and linux OS - only for windows

Most likely nonsense what they say. Standard support answer.
Almost no manufacturer officially supports Linux. Which does not mean the Linux drivers are incompatible.
Try as I said. If it fails in windows, you may get warranty.

Requesting you please share any tutorial which I can follow to install the graphic card drivers

@Mart This should mean that nvidia driver is installed and working in Windows, correct? So no HW issue?

I was in suspicion that i915 overrides nouveau and it doesn’t let nvidia proprietary drivers work as well. In another pc where nvidia driver works, it only has nvidia related modules on “video”.

I tried to blacklist “i915” from /etc/modprobe.d/blacklist.conf but it didn’t work - i915 still shows up.

I’m not sure if it’s bios problem - I tried to change it such as disabling internal graphics or such stuff. I don’t know why but all those efforts ended up with linux not booting up.

Any thoughts please?

@Mart please find attached the log of my system in which I am trying to install the graphic card. I am installing Titan RTX in Ubuntu 20.04 its desktop version I have also tried ppa repo
nvidia-bug-report.log.gz (217.0 KB)

You will need the i916 driver for sure!
But nouveau should be blacklisted, it will interfere with the nvidia driver and block access to the gpu.
Most likely you also should not disable the integraded gpu in BIOS.

You should update your BIOS.
Also why are you using the legacy 470 driver? Why not the current production 535 version?