Nvidia Splash Screen Frozen

I am only getting the Nvidia Splash Screen after booting the computer. The system then freezes goes no further). I have tried different 5v 2amp power supplies and two different SD cards. Any suggestions?

Hi travelfrost,

We’re using 5V power adapter.
Please try plug-in 5V power adapter and micro-USB cable to power on again.

Please refer: https://developer.nvidia.com/embedded/dlc/jetson-nano-dev-kit-user-guide

Hi, turns out it was an issue with the SD cards. I had tried three (ADATA 128gb, Lexar 32gb, Kingston 32gb) and the fourth one worked (Patriot 32gb). Hope this helps others.

Dear moderator,
I’ve just bought 2 same Jetson Nano. I followed all instruction in guide.
And first one works as expected, but second one (with same sd-card and same usb-power) freezes as boot screen. Is it defective?

Hi nesoriti,

Could you try with another USB cable? Sometimes the cause was the cable quality.

Thanks

Y

Thank you for the response.
Can devices be different?
I’ve tried 2-3 cables and 1st device works, 2nd doesn’t

nesoriti,

Does it freeze right after your first flash? Could you hotplug the monitor after boot up instead of connecting it in the beginning?

I’ve tried both. result is same.

Can it be important: I’ve tried to run without a flash-card first time?

I have attached my solash screen image and block being used… I am using a sandisk micro sd 32 freshly imaged.

Since reading all the posts, and seeing this issue can be multiple things… Would it be possible to just trade this one, and pay a little more so you could ship me a working one with all the components instead of having me through trial and error figure it out?

UPDATED!!!

Actually… I’m hoping I just downloaded and installed the wrong image on my sd card… I did notice after searching a bunch more there is a specific 2Gig version. Which I do not think was the file following the initial tutorial. They only differ by an additonal 2gig in the filename.

FYI, for me it was the updated image file that worked.

1 Like

I had the same bug! I had just googled for “Jetson Nano Dev Kit” and got the normal jetpack download (nano-jp451)–this makes the 2GB hardware show the NVIDIA logo and then just hang forever.

Instead, once I downloaded the 2GB firmware from here it worked perfectly! Getting Started with Jetson Nano 2GB Developer Kit | NVIDIA Developer

(NVIDIA, it’s poor branding and frustrating to have multiple silently incompatible firmware images for the 2GB and 4GB versions of the same “Jetson Nano Dev Kit”. I was about to return the device and give up on the Jetson forever! Any chance of a unified jetpack that works on any Jetson, or at least any Jetson Nano, for the next rev?)

nano 2G can Successfully used 256G Micro SD,but Nano 4G went black once,After using SD Card Formatter formatted SD card, burn it again and light it.I’m using a SanDisk 256G Micro SD

Same with me, I downloaded the wrong image - I have the 2GB model. Reimaging the SD card with the 2GB specific image solved my problem.

I have the same problem with Samsung 32 GB SD card. Is the Nano specific to some SD card? I have a Raspberry Pi 4 Model B and it works on all the SD cards I have (Samsung, SanDisk (16GB, 32 GB, and 64 GB)

I had downloaded the wrong image - I have the 2GB model… downloaded the jetson-nano-2gb-jp451-sd-card-image and it boots up.

i get the same problem. it worked the first time but then i remember after using it for a while connected to internet and installing stuff, i then went to do the remote install of isaac kaya sdk. it ends successfully requesting a reboot of the remote jetson. but it doesnt reboot. so i rebooted manually. sudo reboot. and then it stayed on nvidia logo, even when reflashing a totally different SD card. is it possible somethings triggered in the BIOS? did both my sd cards buckle under all that image writing and operating system function? ive got the original 4gb A02 model

i see something that could be the root of the problem.

so as you know nowadays we are on jetpack 4.5.1

and now there are two jetsons,
the original 4GB one with the code A02 on the chip
i presume corresponding to
jetson-nano-jp451-sd-card-image.zip

and then the new kid on the block the 2GB one with code b01 on the chip
i presume corresponding to
jetson-nano-2gb-jp451-sd-card-image.zip

but something strange with the image name after you unzip
jetson-nano-jp451-sd-card-image.zip

the filename is sd-blob-b01.img

did someone at nvidia burn the wrong image of jetson 4.5.1 for the original folks with the 4GB one with the code A02 on the chip ???

i ended up using SDK Manager from a linux desktop and it worked fine. but whats up with doing it the SDK Card way? i tried the image for jetpack 4.5.1 and 4.4 none of them worked.

Hi Juan.

I’m having the same issue with my jetson nano, but with 2GB. It worked for about 10 days, then suddenly stopped booting.

I tried different jetpack versions 4.5 and 4.5.1 (using the 2GB image) and sd cards, but no response, the board is always looping at the nvidia logo.

How can I flash the board using SDK manager? I installed the SDK manager on my laptop, but I don’t know how to connect the board to it in order to flash it.

Also, I don’t know how to dump to boot log. I tried connecting the UART pins from the board to my laptop, but I have nothing. Any help with this?

Thanks!

Check what I posted in the top of forum board to dump the log.

https://forums.developer.nvidia.com/t/guide-for-how-to-file-a-topic-and-what-info-is-necessary-to-share/177457/2

And sdkmanager page.

https://docs.nvidia.com/sdk-manager/index.html