nvidia-uvm not found 340.24 6.5 rc ubuntu 14.04 64 bit kernel 3.13

My computer has an nvidia 520M, Ubuntu 14.04 64 bits with kernel 3.13 installed, CUDA toolkit 6.5rc and nvidia-340.24 driver from xorg edgers. Installation and samples compilation went perfectly, but I can’t run any simple because it says

modprobe: FATAL: Module nvidia-uvm not found.

I have read other topics like “334.21 driver returns 999” and tried the exposed solutions and now I can’t even acces my Desktop.

When I run

dkms install -m nvidia-340-uvm/340.24

It says that kernel 3.12 is already patched or something like that. So the only think that I can figure out is that my kernel is 3.13 and cuda is trying to path 3.12 kernel.

Does anyone know any solution?

Thank you in advance.

Might be a packaging mistake by whoever maintains that PPA.

Is there a reason why you need CUDA 6.5 ? I know ubuntu 14.04 handles CUDA 5.5 just fine.
On my card GeForce GT 645M as of yesterday I had issues when trying to install 6.5

The corresponding Nvidia driver 331 matches up with CUDA 5.5

dpkg --list | grep nvidia | grep ^ii | cut -c1-88
ii nvidia-331 331.89-0ubuntu1~xedgers14.04.2
ii nvidia-331-dev 331.89-0ubuntu1~xedgers14.04.2
ii nvidia-331-uvm 331.89-0ubuntu1~xedgers14.04.2
ii nvidia-common 1:0.2.91.5
ii nvidia-libopencl1-331 331.89-0ubuntu1~xedgers14.04.2
ii nvidia-opencl-icd-331 331.89-0ubuntu1~xedgers14.04.2
ii nvidia-prime 0.6.2
ii nvidia-settings 340.24-0ubuntu1~xedgers14.04.1

A quick way to confirm your CUDA is OK issue the make command
in below dir then as sudo issue :

~/NVIDIA_CUDA-5.5_Samples/1_Utilities/deviceQuery $ sudo ./deviceQuery

./deviceQuery Starting…

CUDA Device Query (Runtime API) version (CUDART static linking)

Detected 1 CUDA Capable device(s)

Device 0: “GeForce GT 645M”
CUDA Driver Version / Runtime Version 6.0 / 5.5
CUDA Capability Major/Minor version number: 3.0
Total amount of global memory: 2048 MBytes (2147287040 bytes)
( 2) Multiprocessors, (192) CUDA Cores/MP: 384 CUDA Cores
GPU Clock rate: 780 MHz (0.78 GHz)
Memory Clock rate: 900 Mhz
Memory Bus Width: 128-bit
L2 Cache Size: 262144 bytes

Try installing http://packages.ubuntu.com/trusty/amd64/nvidia-331-uvm/download

I got the same error but manually starting module fix the issue. Try this:

sudo modprobe nvidia-340-uvm