NVIDIA Xavier AGX board does not connect to the PC monitor

Please provide the following info (tick the boxes after creating this topic):
Software Version
DRIVE OS 6.0.6
DRIVE OS 6.0.5
DRIVE OS 6.0.4 (rev. 1)

Target Operating System

Hardware Platform
DRIVE AGX Orin Developer Kit (940-63710-0010-300)
DRIVE AGX Orin Developer Kit (940-63710-0010-200)
DRIVE AGX Orin Developer Kit (940-63710-0010-100)
DRIVE AGX Orin Developer Kit (940-63710-0010-D00)
DRIVE AGX Orin Developer Kit (940-63710-0010-C00)
DRIVE AGX Orin Developer Kit (not sure its number)

SDK Manager Version

Host Machine Version
native Ubuntu Linux 20.04 Host installed with SDK Manager
native Ubuntu Linux 20.04 Host installed with DRIVE OS Docker Containers
native Ubuntu Linux 18.04 Host installed with DRIVE OS Docker Containers

Hi, I have an issue where after successfully flashing the NVIDIA Drive Xavier AGX hardware according to the documentation and connecting a PC monitor to the designated HDMI port and then booting up the board. Nothing shown on the monitor, and although the monitor detects that it is connected to a machine but it goes into sleep mode.

Does that indicate any problem with the Xavier board? Or maybe I missed a step or a configuration to have the monitor connect properly.

I tried to enable the remote desktop through VNC but also had some trouble with it. Do you have a comprehensive guide on how to setup VNC on NVIDIA Xavier?

Dear @ussama.naal,
Did you follow the steps in Install DRIVE with SDK Manager :: DRIVE Platform Installation Guide with NVIDIA SDK Manager to enable display ?

Hi SivaRamaKrishnaNV, I don’t think I have done the enable display step. Let me try that and hopefully that’s it.

After going through the document you recommended again.

Searching for these error led me to this page: Error trying to connect monitor - #14 by jber4282

Any recommendation on how to deal with this issue with FMON_NVDISPLAYHUB? I tried to increase the brightness of the screen. I tried a different cable and a different screen but of same type but I still get the same problem about the rate xxxxx is below a certain value.

Dear @ussama.naal,
The FMON_NVDISPLAYHUB messages does not cause display issue.

Ok, then why the monitor does not turn on? as I said I did flash the board completely Tegra A+B and then followed the instructions to enable the display:

$ sudo apt update
$ sudo apt install gdm3 ubuntu-unity-desktop

I also tried sudo -b X -ac -noreset -nolisten tcp which is then when I started getting the FMON_NVDISPLAY_HUB messages on the putty console. Still the monitor does not come up.

Dear @ussama.naal,
Does this issue still need support? Could you check changing monitor as well. We notice this helped few customers.

I tried two other monitors but of the same brand (LG) and had the same issue. I don’t have access to a different brand at the moment. But I want to try this at some point (do you have recommendation of which brands work best).

For now I have managed to connect to the device through vnc.