NVIDIA Xavier NX Board Not Booting and Unable to Enter Recovery Mode After SSD Partitioning - Need Help!


I’m facing a complex issue with my NVIDIA Xavier NX board where it’s failing to boot beyond the initial setup screen (the one with options like F11, ESC, etc.). Here’s a chronological breakdown of the problem and the steps I’ve taken:

  1. Initial Setup: Successfully set up the system on the SSD and rebooted to the SD card’s system.

  2. Partitioning the SSD: While logged into the system on the SD card, I resized the SSD into two partitions: one for the file system and one for EFI. I manually copied the original EFI directory to a new partition (formatted as FAT32, flagged as boot, esp; 1GB at the end of the disk).

  3. First Reboot Failure: After partitioning, I rebooted with both SSD and SD card. I manually chose SSD, but it didn’t enter, just repeated the setup screen. Then I chose SD, and nothing showed after a long wait.

  4. Subsequent Testing:

    • Removed the SSD and tried booting with the SD card that had previously worked. The problem persisted.
    • Tried another SD card with an installed Ubuntu system, but no improvement.
    • Attempted to enter recovery mode by shorting Pin 9 and Pin 10, connecting the micro USB to my PC, and powering up the NX. Nothing showed as connected in the SDK manager.


  • The issue seems unrelated to the SD card or SSD, as the problem persists across different storage devices.
  • Something on the NX board seems to have changed after the reboot, but I’m unsure what it could be.

Request for Assistance:
I’m seeking guidance on what might have caused this issue and how to fix it. The problem began after partitioning the SSD while logged into the SD card’s system, and now the board won’t boot properly. If additional information is needed, please let me know, and I’ll provide it promptly.

Thank you in advance for your help!

What’a the purpose of a dedicated EFI partition? From where did you get the idea to do so?
I don’t think it’s supported and please don’t do that. Re-flash the device first.

Also, do you see the device with lsusb on your host PC?
Force recovery mode is only related to hardware components, and it should still work even if everything in the storage device is messed up.

Thank you, DaveYYY, for your guidance.

Reason for Modifying EFI: I attempted to resize the file system at /dev/nvme0n1p1 following the tutorial found in this NVIDIA Developer Forum thread. During this process, I removed other partitions without deleting data and moved nvme0n1p11 to the end of the disk using the script provided in the thread. I noticed that there were no files in it, so I copied the contents originally inside /dev/nvme0n1p11 (which contained only /EFI/boot/BOOTAA64.efi).

Issue with USB Connection: After spending the entire night trying different approaches, I’m unable to detect the device using the ls -al /dev/ttyUSB* or lsusb commands. The lsusb command returns the following lines, regardless of whether the micro USB is plugged in or out:

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 006: ID 0bda:b82c Realtek Semiconductor Corp. 802.11ac NIC
Bus 001 Device 002: ID 0bda:8179 Realtek Semiconductor Corp. RTL8188EUS 802.11n Wireless Network Adapter
Bus 001 Device 004: ID 058f:6366 Alcor Micro Corp. Multi Flash Reader
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Without a USB connection, I’m at a loss for how to reflash the device. I’m concerned that my modification to the EFI may have inadvertently altered the hardware’s boot firmware, preventing normal booting and recovery mode access.

Hardware Setup: The hardware setup is depicted in the image below, and this connection worked before the change of EFI partition modification:

I appreciate your continued assistance and look forward to any further guidance you can provide.

The partition will automatically get enlarged upon boot, so please do not try to modify any partitions manually.

What’s the two yellow cables in the picture?
Supposedly, there should be a jumper across these two pins.
For UART connection, I don’t see the TXD and RXD pins connected, so of course you won’t see it with ls -al /dev/ttyUSB*

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.