nvidia-xconfig doesnt do what i want it to, nor does nvidia-settings

How do I configure the offload mode? Nvidia X Server Setting is displaying blank screen.

I fixed it by going to login screen and selecting Zorin and not Zorin on Wayland.
Thanks a lot @generix Btw what’s the difference between the two and how can I go back to my iGPU option?

It’s a different/new display server model from the traditional Xorg/X11.
Looks like Zorin is based on Ubuntu so
sudo prime-select intel
and reboot should work.

1 Like

Is the performance of both Xorg and Wayland different? And since I am using AMD CPU and Nvidia GPU so will the prime-select intel thing work? Or do I have to do anything different? And sorry for asking so many questions. Thanks a lot again. And do I have to do that peristance thing which you had mentioned at the place where the link to this page was present.

With wayland, only the amd gpu will be useable.
You’ll have to use prime-select intel despite of having an amd gpu because Ubuntu’s prime-select doesn’t support that ootb yet.

Hi generix

Could you suggest a solution to me too ?
Many many thanks in advance

nvidia-bug-report.log (3.5 MB)

You have a standard intel/nvidia Optimus system, you didn’t need to do anything. Please

  • delete /etc/X11/xorg.conf
  • remove “PrimaryGPU” option from /usr/share/X11/xorg.conf.d/10-nvidia.conf
  • reboot
    If this doesn’t resolve the issue, please create a new nvidia-bug-report.log.

Unfortunately nothing changed.
In addition, on the first login I see strange things on the desktop

image

nvidia-bug-report.log (3.4 MB)

Thanks again generix

Please also delete the file
/usr/share/X11/xorg.conf.d/80-backlight.conf
it sets some intel config.

Something changed. I don’t have that strange “green stuff” on the desktop.

But: I noticed that at the login the driver was not loaded.
nvidia-smi returned

NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

As soon as I run sudo optirun glxgears -info (even if it does not print anything) it starts to “work” again (I’m not sure that is working because I see no processes at all in the list)

±----------------------------------------------------------------------------+
| NVIDIA-SMI 440.64 Driver Version: 440.64 CUDA Version: 10.2 |
|-------------------------------±---------------------±---------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
|===============================+======================+======================|
| 0 GeForce MX150 Off | 00000000:01:00.0 Off | N/A |
| N/A 51C P0 N/A / N/A | 0MiB / 2002MiB | 0% Default |
±------------------------------±---------------------±---------------------+

±----------------------------------------------------------------------------+
| Processes: GPU Memory |
| GPU PID Type Process name Usage |
|=============================================================================|
| No running processes found |
±----------------------------------------------------------------------------+

Here attached the log again

Thanks a lot

nvidia-bug-report.log (3.4 MB)

If you have bumblebee installed (obviously) it will unload the driver and turn off the nvidia gpu on boot.
You’ll have to decide whether to use bumblebee, PRIME output or PRIME offload.

Ok thank you.

So at the end we can say that I’m using the driver?
And…sorry but could you explain the differences between the three options? What you suggest?
With which of the solutions you mentioned I can have nvidia-settings fully working?

Sorry for all the questions but are days I’m trying to clarify some aspects and I found only here some tips.

Thanks

Since this is an Optimus notebook, nvidia-settings won’t give you much besides monitoring gpu usage/temperatures. There’s nothing to tweak.
Bumblebee/optirun/primusrun is the infrastructure to make use of hybrid graphics from times when PRIME was not available. It still has its use when you’re into maximum power saving. For maximum performance, rather uninstall it and switch to PRIME.

1 Like

Now everything is more clear!
Thanks a lot. You did the trick!

@generix Hello generix,

I followed these methods to my asus rog G15 which has NVIDIA and AMD inbuilt gpu.

I changed modified /usr/share/X11/xorg.conf.d/10-amdgpu.conf
replacing only

Driver "amdgpu"

with

Driver "modesetting"

Then, I added Option “PrimaryGPU” “Yes” in 10-nvidia.conf. this leads to freeze my display when ubuntu is loading. Also, after i created optimus.desktop files, it lead the screen to freezed. So i deleted that and did the rest you mentioned.

When i typed following line,

__NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia glxinfo | grep vendor

gives me following results.
XIO: fatal IO error 17 (File exists) on X server “:1”
after 47 requests (47 known processed) with 0 events remaining.
XIO: fatal IO error 17 (File exists) on X server “:1”
after 47 requests (47 known processed) with 0 events remaining.

xrandr --listproviders
Providers: number : 1
Provider 0: id: 0x1b6 cap: 0x0 crtcs: 0 outputs: 0 associated providers: 0 name:NVIDIA-G0

xrandr --setprovideroutputsource modesetting NVIDIA-0
Could not find provider with name modesetting

xrandr --auto
xrandr: Failed to get size of gamma for output default

It seems that i can open nvidia-settings. But it is still shows OpenGL renderer string: llvmpipe (LLVM 9.0.1, 128 bits)

Can you help on this ?

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post. You will have to rename the file ending to something else since the forum software doesn’t accept .gz files (nifty!).

Here is my bug report.

nvidia-bug-report.log (2.1 MB)

Your amd cpu is too new for the running 5.4 kernel. Please check if upgrading to latest 5.6 kernel makes the amd gpu work.

Hi @generix,
I have following setup:


with AMD Ryzen 5 CPU and NVIDIA GTX 1050 GPU and I have 2 screen setup and I’ve spent a lot of time trying to enable both screens to work (HDMI port is going directly to nvidia) on my ubuntu 20.04 and everything I’ve tried failed.
I did not except above to work as you mentioned:

Downside of this is that no external monitors connected to the nvidia gpu will work.

So, my question is - is it possible to have 2 screens working with my configuration? I mean, I just bought this laptop and I think quite a few people might have this problem as well.

Thanks.

nvidia-bug-report.log (449.8 KB)

You put Option "PrimaryGPU" "Yes" into the wrong file.
Furthermore, you misunderstood my initial post, it describes two different possibilities:

  1. nvidia always on - external monitors supported
  2. nvidia on-demand - external monitors not supported.
1 Like