nvidia-xconfig doesnt do what i want it to, nor does nvidia-settings

Looks like a driver regression, I can repoduce it on the 450 driver. Please run nvidia-bug-report.sh as root and mail the resulting nvidia-bug-report.log.gz with a description of the bug to linux-bugs[at]nvidia.com for additional attention.

1 Like

Thanks for your answer and time. Just out of curiosity and bc you were able to reproduce this bug, is it PRIME related? I have no non-OPTIMUS system to try this on so I cant tell.

I came to testing this and it’s only an issue on PRIME, it’s working on a discrete nvidia system.

Is anyone tracking this bug @generix? I sent the report a while ago. I could use some older driver in the meantime

IDK, I’m just a regular user, no nvidia employee.

Oh sorry, you sound like one! Thanks for your time

Hi, everybody!

I have a ASUS TUF FA506IV laptop. I have tried installed Ubuntu 20.04 dozens of time because I can not get Nvidia-settings work on my RTX2060. I’m aware this is an AMD/NVIDIA issue, I tried everything that was mentioned above and in other forums, but I still either get frozen after boot or get small empty window after starting nvidia-settings. I attached bug-report file…

Thanx

nvidia-bug-report.log.log (357.7 KB)

@generix
Description of Problem: When i am opening NVIDIA X server settings in Ubuntu it looks like this - https://ibb.co/yyJxsQJ , totally blank and when i am running the command “nvidia-smi” it shows this - https://ibb.co/qJCSsrD

Computer Type:Laptop , HP pavilion 15-ec0062AX
GPU:Geforce GTX 1050 max-q,3GB of VRAM, No overclocking.
CPU: Ryzen 5 3550h, no overclock
Motherboard: NA
RAM: 8GB DDR4 2400MHz, no overclock
Operating System & Version: ubuntu 20.04LTS, Clean install
GPU Drivers: 440.100 , clean install
BIOS : Secure boot disabled

Troubleshooting: I tried clean install of ubuntu , adding repo , manually clean install of gpu driver , checking the option of installation of propreitary driver while installation of ubuntu, installed 435 same thing happened then upgrading to 440 didnt solved the issue and vice versa but issue still occurs.

and i this file - /etc/X11/xorg.conf doesnt exist.

Welcome in the club… I’m having the same problem… As we can see it happens with AMD/NVIDIA hardware…

1 Like

Ok i solve the issue i just simply followed the steps here- https://askubuntu.com/questions/1177248/nvidia-gtx-1650-not-detected-in-ubuntu-18-04-3
and the steps generix said and boom and i can access my settings again.

Hello,

Im new to this forum. I have Asus Zephyrus G15 with Ryzen 5 4800HS and Nvidia 2060 Super. Im trying to get the mode where i use radeon to display X and nvidia for certain application like games.

I think i have got it working but im not sure.

[22:22] chris@gentoo ~ __NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia glxinfo | grep vendor server glx vendor string: NVIDIA Corporation client glx vendor string: NVIDIA Corporation OpenGL vendor string: NVIDIA Corporation [22:23] chris@gentoo ~

And without the variables :

[22:23] chris@gentoo ~ glxinfo | grep vendor server glx vendor string: SGI client glx vendor string: Mesa Project and SGI OpenGL vendor string: X.Org [22:23] chris@gentoo ~

So according to that it seems to work. But when i run glxgear with the variables to enable the NVIDIA gpu and then check nvidia-smi it says that NVIDIA 2060 Super is Off.

[22:23] chris@gentoo ~ $ nvidia-smi
Mon Jul 13 22:24:50 2020
±----------------------------------------------------------------------------+
| NVIDIA-SMI 450.57 Driver Version: 450.57 CUDA Version: 11.0 |
|-------------------------------±---------------------±---------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
| | | MIG M. |
|===============================+======================+======================|
| 0 GeForce RTX 206… Off | 00000000:01:00.0 Off | N/A |
| N/A 46C P8 8W / N/A | 12MiB / 5934MiB | 26% Default |
| | | N/A |
±------------------------------±---------------------±---------------------+

±----------------------------------------------------------------------------+
| Processes: |
| GPU GI CI PID Type Process name GPU Memory |
| ID ID Usage |
|=============================================================================|
| 0 N/A N/A 5566 G /usr/bin/X 6MiB |
| 0 N/A N/A 6853 G glxgears 3MiB |
±----------------------------------------------------------------------------+

So is it working or not ?

Best regards

Also. xrandr --listproviders give:
Providers: number : 2
Provider 0: id: 0x45 cap: 0xf, Source Output, Sink Output, Source Offload, Sink Offload crtcs: 4 outputs: 2 associated providers: 1 name:modesetting
Provider 1: id: 0x1f8 cap: 0x2, Sink Output crtcs: 4 outputs: 2 associated providers: 1 name:NVIDIA-G0

So i guess the xrandr --setoutputprovidersource should use NVIDIA-G0 and not NVIDIA-0 ? But when i do xrandr --setoutputprovidersource modesetting NVIDIA-0 it says

[00:24] chris@gentoo ~ $ xrandr --setprovideroutputsource modesetting NVIDIA-0
Could not find provider with name NVIDIA-0

but with NVIDIA-G0 i get

[00:24] chris@gentoo ~ $ xrandr --setprovideroutputsource modesetting NVIDIA-G0
X Error of failed request: BadValue (integer parameter out of range for operation)
Major opcode of failed request: 139 (RANDR)
Minor opcode of failed request: 35 (RRSetProviderOutputSource)
Value in failed request: 0x1f8
Serial number of failed request: 16
Current serial number in output stream: 17

Yes, I think this means it’s working. The nvidia-smi table is a little confusing; the “Off” you’re referring to in the table is for the persistence mode feature, and this just means that persistence mode is disabled on that GPU. That’s fine since your X server is keeping the GPU initialized and persistence mode isn’t needed for your use case.

For xrandr, the --setprovideroutputsource option is for using outputs on one GPU to display the desktop from another GPU, a mode referred to as “display offload”. It’s not needed for “render offload”, which is the mode I think you’re trying to use.

I see. Hmm when i try to start a game (Wow) with wine that has vulkan installed. The screen just freezes. Although when i alt tab the program selector shows up but the program i choose is not displayed (Wow is in windowed fullscreen mode). What can cause this? Where should i look to solve it?

Hello, there’s a option in ASUS TUF BIOS called “UMA Frame Buffer Size” with two options on latest BIOS

  1. 512M 2. Auto
    This sets the iGPU vram size. Auto sets it to 2GB.

In old BIOS, it had options of 128M and 512M

I got both GPUs working by:

Disable Secure Boot
Install kernel 5.7 ( try new stable builds )
Install nvidia ppa
Install nvidia 450 drivers from additional drivers settings

I got HDMI working by disabling iGPU as said in post 7 first part.

Hi Thanks for the assistance ( @generix Nov 23, 2019 ) I was redirected here from Ask Ubuntu. The changes to the conf files as you had detailed has sorted out the HDMI output on my ASUS FX505D with GeForce GTX 1650 running Ubuntu 20.04.1LTS.

Appreciate the hard work…