NvIFR_CreateEx succeeds, though pNVIFR is null


I am experimenting with H264 encoding. My code is very minimal and appears something like this

hr = D3D11CreateDevice(NULL, D3D_DRIVER_TYPE_HARDWARE, NULL, 0, NULL, 0, D3D11_SDK_VERSION, &pDevice, &featureLevel, &pDeviceContext);

NVIFR_CREATE_PARAMS params = { 0 };
params.dwVersion = NVIFR_CREATE_PARAMS_VER;
params.dwInterfaceType = NVIFR_TOH264HWENCODER;
params.pDevice = pDevice;


NvIFR_CreateEx_fn succeeds and returns NVIFR_SUCCESS.
However params.pNvIFR is null.

Does anyone have ideas on how to get this work correctly?


I compiled DX10IFR_AsyncH264Encode sample from Nvidia. It also failed with the same error "Failed to create the NvIFRToH264HWEncoder".

I am using NVidia’s Windows 2008 server AMI in Amazon AWS with Visual Studio Express 2013.

Any help will be highly appreciated.


Hi geeklin, Thanks for reporting this issue. Is the issue also reproduce on bare-metal OS/non-virtual-machine? Can we get standalone sample application/program/code to reproduce this issue? What GPU install and nvidia driver version on system? Please provide reproduction steps in details and any extra information that will help us to duplicate this issue inhouse to investigate?

Thanks sandipt. I am afraid I only have access to a virtual windows machine. I’ll send you more information about reproduction in a private message.

Driver version Driver Date 7/1/2013.
Chip GRID K520

The issue is solved after upgrading to Driver date 3/24/2014 driver version

Great …