nvjpegenc Causes Segfault

I am trying to deccode streams with the following pipeline:

But I get this error.
0x0000007f9c56734c in jpegTegraEncoderCompress ()
from /usr/lib/aarch64-linux-gnu/tegra/libnvjpeg.so

Checked https://devtalk.nvidia.com/default/topic/1005580/nvjpegenc-segmentation-fault/ and https://devtalk.nvidia.com/default/topic/1064228/nvvideoconvert-nvjpegenc-faulty-cooperation/ but could not get a solution.

nvjpegenc version: 1.2.3

I want the sink as jpegs as to process them in another application. It works with jpegenc but I think I can improve performance with nvjpegenc

Please try nvvideoconvert. While running DeepStream SDK, nvvideoconvert should be used.


I tried that but I still get :

0x0000007f9c3f534c in jpegTegraEncoderCompress ()
   from /usr/lib/aarch64-linux-gnu/tegra/libnvjpeg.so

Do you have any example that uses nvjpegenc with nvvideoconvert. I am completely lost.

Please see https://devtalk.nvidia.com/default/topic/1066986/deepstream-sdk/nvjpegenc-keeps-crashing-no-matter-what-i-try/

Please try

gst-launch-1.0 uridecodebin uri=rtsp://ip:554/Streaming/Channels/102?transportmode=unicast ! nvvideoconvert ! 'video/x-raw, formt=(string)I420' ! nvjpegenc ! multifilesink location=img_%03d.jpeg

And it seems not necessary to duplicate topic.

It still fails.
I get

nvvideoconvert gstnvvideoconvert.c:2941:gst_nvvideoconvert_transform: buffer transform failed

We can run the command on Jetson Xavier. Please share which platform you use. It may be specific to the platform.

Apologise for the late reply, I was away. Platform details:

NVIDIA Jetson NANO/TX1 - Jetpack 4.2.1 [L4T 32.2.0]

Please check if the prebuilt lib helps the usecase.

It fixes an issue of running IP cameras in TCP mode.