nvlink fatal : Input file '/usr/lib64/libcudadevrt.a:cuda_device_runtime.o' newer than toolkit

Hi, I try to make a cuda fortran environment on my laptop which now runs Fedora 27 (64 bit). My computer has two graphic cards: a nvs 315 and a Quadro P5000.

I followed the instructions on the website: https://negativo17.org/nvidia-driver/ to install the cuda packages (some blogs say that it works) and I installed the Community Edition PGI compiler (version 18.4).

The system now sees two graphic cards:

$ sudo lspci | grep -i nvi
02:00.0 VGA compatible controller: NVIDIA Corporation GF119 [NVS 315] (rev a1)
02:00.1 Audio device: NVIDIA Corporation GF119 HDMI Audio Controller (rev a1)
03:00.0 VGA compatible controller: NVIDIA Corporation GP104GL [Quadro P5000] (rev a1)
03:00.1 Audio device: NVIDIA Corporation GP104 High Definition Audio Controller (rev a1)

However, when I compile the deviceQuery, I get the following information:

$ make
pgf90 -Mcuda=cc60 -O2 -o deviceQuery.out deviceQuery.cuf
nvlink fatal   : Input file '/usr/lib64/libcudadevrt.a:cuda_device_runtime.o' newer than toolkit
pgacclnk: child process exit status 2: /opt/pgi/linux86-64/18.4/bin/pgnvd
make: *** [Makefile:29: build] Error 2

Can anybody please help me to see what’s the problem?

I see in the Nvidia website that the latest cuda toolkit 9.1 supports Fedora 25, not Fedora 27. May this be the reason?

Before using the solution provided on https://negativo17.org/nvidia-driver/, I tried to install cuda toolkit 9.1 on Fedora 27, but my Fedora 27 can not start after installing the toolkit.

Shall I follow strictly the cuda toolkit requirement and install Fedora 25 instead of 27? Or is there work around?

thanks!

Hi,
I’ve been getting the exact same error on my system.
This thread seems dead, did you find a solution for this?