NvMedia limits for NvMediaImage allocation

Dear Support,

I have attempted to use several high resolution cameras (many 2,3Mpx and some 5,4Mpx cameras using only one Tegra) through NvSIPL.
Depending on the number of cameras, resolution and the size of the ICP and ISP buffers allocated for the pipeline, I run into the following error in some configurations:

NvMediaLimit:
NvMapMemAllocInternalTagged: 1074810371 error 12

I have searched through the NvSIPL and NvSciBuf related documentation, however I could not find exact values for the NvMedia specific limits.

Could you please point me in the right direction, how to find out the exact value for the size of memory available for images created with NvMediaImageCreateFromNvSciBuf?

Thank you very much in advance!

Software Version
DRIVE OS Linux 5.2.6
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version
other

Target Operating System
Linux
QNX
other

Hardware Platform
NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)
other

SDK Manager Version
1.6.1.8175
1.6.0.8170
other

Host Machine Version
native Ubuntu 18.04
other

Dear @krisztian.holman,
Could you share the camera modules and commands to reproduce the issue.

Dear SivaRamaKrishnaNV,

Unfortunately the NvSIPL camera example cannot be used for this purpose as it does not support the mixing of platform configs, reproducing the issue requires an application built using the NvSIPL API.

I belive that, the exact limit could be tested by creating images with consecutive NvMediaImageCreateFromNvSciBuf calls and one could determine the value of this limit based on the image attributes and the number of successfully allocated NvSciBuf objects.

Would it be possible to share the NvMedia specific limits or include them in the DriveOS documentation instead?

Thank you very much in advance!

Hi, @krisztian.holman
This looks out of memory. Did you mean the message was ejected in calling NvMediaImageCreateFromNvSciBuf()?

Please refer to nvsipl_camera for running with multiple cameras and see if you can reproduce the issue with it.