NVML Sanity error in nvidia-healthmon

Can some one please tell me how I can fix the following error recieved upon running nvidia-healthmon?

Loading Config: SUCCESS
Global Tests
Black-Listed Drivers: SUCCESS
Load NVML: SUCCESS
NVML Sanity
The driver version “6.331.38” does not contain a supported version of
NVML.
Result: CRITICAL ERROR
Global Test Results: 2 success, 1 errors, 0 warnings, 0 did not run

Thanks!

Take a look at healthmon’s user guide pdf chapter 1.2 dependencies. Healthmon requiers nvidia’s “developers driver” (e.g. The one that ships with cuda sdk). I think the latest dev sdk is 319…sth. Definitely not 331.
Hope this helps.

BTW. Next time please attach the version nb of the healthmon and the driver.

Cheers,
Przemek