NVRM Xid 32 on ubuntu 18.04

Hi,

I always get the NVRM Xid 32 error every time my pc suspend or sleep.
I am using MX150 GPU with Nvidia 396.18 drivers on Ubuntu 18.04. Can this be a bug on a driver?

Thanks advance
nvidia-bug-report.log.gz (121 KB)

Im having the same problem, found any fix?

Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post will reveal a paperclip icon.

The nvidia-bug-report attached.

It should be a bug-report.log which contains the actual error.

Nevertheless, two things you could try:

  1. Enable Prime sync:
    create a file /etc/modprobe.d/99-prime-sync.conf containing
options nvidia_drm modeset=1

afterwards, run
sudo update-initramfs -u
and reboot.
If done right,
sudo cat /sys/module/nvidia_drm/parameters/modeset
should return ‘Y’.

  1. set the console frambuffer resolution to match the screen resolution
    Add kernel parameter
    video=efifb:width:1920,height:1080
    to grub config, run sudo update-grub and reboot.

How do I do the step 2? Also, in my case, the screen is 4k, so what parameters do I put?

Nevermind, I found how to do the step 2.

Tried both of them and the error still happens, I attach my log.
https://1drv.ms/u/s!Agn_Ak-lUAfmg6ZvB6nSUuoNaS-JJw (Shared on OneDrive)

@nicolasquirozpa
Your GPU fails to power on after suspend, that’s an acpi bug in the kernel.
For a quick workaround you could try to add
acpi_osi=! acpi_osi=“Windows 2009”
to the kernel cmdline like you did with the video parameter.
Furthermore, kernel 4.17 fixes some of those acpi bugs so if you’re bold you can try to use a 4.17-rc kernel without the parameters.

For further analysis, you would have to run
sudo acpidump >acpidump.txt
and attach that.

@generix
Thanks for the help, but before I came here I already tried the acpi workaround, and I’m not that bold to try a beta kernel (or whatever early stage it is on). I attach the acpidump.txt

https://1drv.ms/t/s!Agn_Ak-lUAfmg6Zz5Y8aunlbfZsGAg (OneDrive Link)

Unfortunately found no switch for a workaround so you can only wait for kernel 4.17 and try that.

Just tried to suspend and then resume on my ASUS X542UA (MX150) on kernel 4.17.2-78 with driver version 390.67 and it worked.

However I’m running Solus and they only have the 390.59 driver packaged at the moment, and it does not work with that version…