NvTbootKernelDTB is corrupted!

Hi, I’m a beginner (I am trying to power up the board for the first time)

I’m using jetson nano p3450, I have followed the instruction for getting started, and every thing was just fine. But after a successful shutdown, the board just wont power up. The green LED is on, but no signal over HDMI.

I read the data being sent over UART while trying to power up (the data are below). I believe the error is obvious but since I am a total noob I’ll need your help to deal with it. And if you can inform me what was the cause I would be grateful.
Thanks in advance

[0000.125] [L4T TegraBoot] (version 00.00.2018.01-l4t-e82258de)
[0000.130] Processing in cold boot mode Bootloader 2
[0000.135] A02 Bootrom Patch rev = 1023
[0000.138] Power-up reason: pmc por
[0000.141] No Battery Present
[0000.144] pmic max77620 reset reason
[0000.147] pmic max77620 NVERC : 0xff
[0000.151] RamCode = 0
[0000.153] Platform has DDR4 type RAM
[0000.156] max77620 disabling SD1 Remote Sense
[0000.161] Setting DDR voltage to 1125mv
[0000.165] Serial Number of Pmic Max77663: 0x422f0
[0000.172] Entering ramdump check
[0000.175] Get RamDumpCarveOut = 0x0
[0000.178] RamDumpCarveOut=0x0, RamDumperFlag=0xe59ff3f8
[0000.184] Last reboot was clean, booting normally!
[0000.188] Sdram initialization is successful
[0000.192] SecureOs Carveout Base=0x00000000ff800000 Size=0x00800000
[0000.198] Lp0 Carveout Base=0x00000000ff780000 Size=0x00001000
[0000.204] BpmpFw Carveout Base=0x00000000ff700000 Size=0x00080000
[0000.210] GSC1 Carveout Base=0x00000000ff600000 Size=0x00100000
[0000.216] GSC2 Carveout Base=0x00000000ff500000 Size=0x00100000
[0000.222] GSC4 Carveout Base=0x00000000ff400000 Size=0x00100000
[0000.228] GSC5 Carveout Base=0x00000000ff300000 Size=0x00100000
[0000.233] GSC3 Carveout Base=0x000000017f300000 Size=0x00d00000
[0000.250] RamDump Carveout Base=0x00000000ff280000 Size=0x00080000
[0000.256] Platform-DebugCarveout: 0
[0000.259] Nck Carveout Base=0x00000000ff080000 Size=0x00200000
[0000.265] Non secure mode, and RB not enabled.
[0000.269] BoardID = 3448, SKU = 0x0
[0000.272] QSPI-ONLY: SkipQspiOnlyFlag = 0
[0000.276] Nano-SD: checking PT table on QSPI …
[0000.280] Read PT from (2:0)
[0000.296] Using BFS PT to query partitions
[0000.301] Loading Tboot-CPU binary
[0000.330] Verifying TBC in OdmNonSecureSBK mode
[0000.340] Bootloader load address is 0xa0000000, entry address is 0xa0000258
[0000.347] Bootloader downloaded successfully.
[0000.351] Downloaded Tboot-CPU binary to 0xa0000258
[0000.356] MAX77620_GPIO5 configured
[0000.359] CPU power rail is up
[0000.362] CPU clock enabled
[0000.366] Performing RAM repair
[0000.369] Updating A64 Warmreset Address to 0xa00002e9
[0000.374] BoardID = 3448, SKU = 0x0
[0000.377] QSPI-ONLY: SkipQspiOnlyFlag = 0
[0000.381] Nano-SD: checking PT table on QSPI …
[0000.385] Loading NvTbootBootloaderDTB
[0000.452] Verifying NvTbootBootloaderDTB in OdmNonSecureSBK mode
[0000.523] Bootloader DTB Load Address: 0x83000000
[0000.528] BoardID = 3448, SKU = 0x0
[0000.531] QSPI-ONLY: SkipQspiOnlyFlag = 0
[0000.535] Nano-SD: checking PT table on QSPI …
[0000.540] Loading NvTbootKernelDTB
[0000.605] Verifying NvTbootKernelDTB in OdmNonSecureSBK mode
[0000.629] NvTbootKernelDTB is corrupted!
[0000.633] Error in NvTbootLoadBinary: 0x14 !
[0000.637] Error is 14

please refer to point 0 in this post. Prepare a non-VM x86_64 ubuntu 18.04 host and flash your jeton nano with sdkmanager.

I had the same issue today, I solved it by using sdkmanager flash OS to Jetson Nano direrctly.
During the flasing, you may occur another issue as following thread:

Don’t worry, you could solved it by installing some utils library on your host machine with:
$ sudo apt-get install exfat-fuse exfat-utils
After finishing install, relaunch sdkmanager, your target Jetson nano should be detected.
Go on to finish left steps of sdkmanager, Your Jetson Nano will come back to life.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.