Nvv4l2h264enc & webrtcbin (GStreamer)


We’ve been making use of GStreamer & webrtcbin on Jetson and desktop Nvidia setups for a few years now, and everything has worked very well.

In the past we found that, when using our pipeline on Jetson, we needed to use the omxh264enc encoder as nvv4l2h264enc had too many bugs in it that clashed with webrtcbin. Recently we finally made the switch to Jetpack 5.0.2 which of course no longer supports the omx encoder.

The problem: When using webrtcbin with nvv4l2h264enc (& nvvidconv) we run into some consistent delays (by as much as 30 seconds!) in the start of the WebRTC streams.


  • Switching to openh264enc fixes the issue.
  • Also, using the same code (and same version of GStreamer) on a desktop machine with nvh264enc also works perfectly well.
  • We are using GStreamer 1.21.1 as we have found it has the fewest issues, but we have also tried with the latest stable versions.

Has anyone else encountered this? Any ideas?

1 Like

Please check if it helps by setting to small idrinterval. And can enable insert-sps-pps, insert-aud, and insert-vui for a try.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.