Nvvideoconvert to RGBA fails with nvdsanaytics plugin

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU)
Jetson Xavier NX

• DeepStream Version

• JetPack Version (valid for Jetson only)

• TensorRT Version
• NVIDIA GPU Driver Version (valid for GPU only)
• Issue Type( questions, new requirements, bugs)

• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
Explained in detail below

• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

I am trying to combine the two example notebooks : image_metadata and nvdsanalytics.

I started with the nvdsanalytics script; I added the piece of code following after the pgie element and before the tracker element:

nvvidconv_postinfer = Gst.ElementFactory.make("nvvideoconvert", "convertor_postinfer-%u"%i)
if not nvvidconv_postinfer:
       sys.stderr.write(" Unable to create nvvidconv_postinfer \n")

caps_postinfer = Gst.ElementFactory.make("capsfilter", "post_infer_filter-%u"%i)
caps_postinfer.set_property("caps", Gst.Caps.from_string("video/x-raw(memory:NVMM),format=RGBA"))


Just adding the above snippet cause the pipeline to build successfully but fails during playing with : Segmentation Fault(core dumped)

Please upgrade to latest deepstream 6.0.

@Fiona.Chen thanks for getting back quickly. Is this definetly a version issue. Im just asking because I have to redo my whole setup.

I have tried with DS 6.0 GA version, I can not reproduce the problem.

hey @Fiona.Chen the issue got solved using Deepstream 6.0. Thanks a lot.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.