Nvvp frozen at launch on MacOS Big Sur

My MacBook Pro is running MacOS Big Sur 11.2.3.
I need to visualize profiling results from nvprof run on a separate target.
I followed all instructions listed at the following link, taking care to install the very specific version of JDK from Zulu builds:

When I run:
/Applications/nvvp/bin/nvvp -vm /Library/Java/JavaVirtualMachines/zulu-8.jdk/Contents/Home/jre/bin/java

… I see a GUI dialog pop up asking to create a workspace for temporary files but none of the buttons (Browse, Ok, Cancel etc.) in it are clickable. nvvp seems frozen. I am able to kill the process by pressing Ctrl-C on the terminal where I ran the command but am not able to do anything else.

Is anyone else seeing this?
Is there a solution to this issue?


NVVP from CUDA 11.2 was not tested and supported for macOS BigSur. Can you please recheck it with the NVVP from CUDA 11.3 toolkit, which is tested with BigSur running on a x86_84 architecture? Which CPU architecture you are trying to run it on?

The new version too just launches a window asking to set up a workspace but freezes.

I am using x86_64 architecture (uname -m).

I just downloaded and installed nvvp from CUDA Dev Tools for 11.3 for MacOS. I deleted my previous installation of nvvp and installed this latest version afresh. I granted the ‘nvvp’ app permission to run from within “Security and Privacy” of “System Settings”. The above observations were made after all these steps.

Hi, were you able to find a solution? I have the same issue with you.

Additional steps might be needed to run NVVP on BigSur.

Make sure that required Java is in your JAVA_HOME environment variable. For example /Library/Java/JavaVirtualMachines/zulu-8.jdk/Contents/Home
Run nvvp executable.


If you get a similar error while loading jvm library:

JavaVM: Failed to load JVM: /Library/Java/JavaVirtualMachines/zulu-8.jdk/Contents/Home/lib/libserver.dylib
JavaVM FATAL: Failed to load the jvm library.

Then create symlink for libjvm.dylib and run nvvp again

sudo ln -s /Library/Java/JavaVirtualMachines/zulu-8.jdk/Contents/Home/jre/lib/server/libjvm.dylib /Library/Java/JavaVirtualMachines/zulu-8.jdk/Contents/Home/lib/libserver.dylib

1 Like

Confirming that the solution proposed by @mjain works (many thanks!).

There is one additional step that I had to perform. After launching nvvp I got a popup saying something like “lib.dylib” cannot be allowed to run because its origin cannot be verified.

To fix this I went into “System Preferences” → Security & Privacy → General and clicked on the “Allow …” button (which was showing the library that was blocked). Then, relaunching nvvp worked correctly.