Nvx_sample_player from VisionWorks 1.6 segfault on Jetpack 4.4

I’m on a Jetson Nano R32.4.3 (# R32 (release), REVISION: 4.3, GCID: 21589087, BOARD: t210ref, EABI: aarch64, DATE: Fri Jun 26 04:38:25 UTC 2020)

I am trying to follow these intructions: Installing CUDA-toolkit and VisionWorks Jetson TX2/Xavier/Nano - RidgeRun Developer Connection

I’ve installed CUDA 10.2 from Jetpack 4.4 and VisionWorks 1.6. When I install and build the VisionWorks-1.6-Samples it builds without error.

I get the following error when I run:

$release> ./nvx_sample_player
VisionWorks library info:
	 VisionWorks version : 1.6.0
	 OpenVX Standard version : 1.1.0

[1]    5316 segmentation fault (core dumped)  ./nvx_sample_player

I get the same error for the other demos as well (nvx_demo_video_stabilizer, nvx_demo_feauture_tracker, etc)

The versions of CUDA and VisionWorks are the following:
cuda-repo-l4t-10-2-local-10.2.89_1.0-1_arm64.deb
libvisionworks-repo_1.6.0.501_arm64.deb

Looks like VisionWorks requires X11, which was removed in an attempt to make a no-desktop/display manager environment.