NX production module not detecting external sd card reader

I’m trying to do what this user did (same NCB00 carrier board) but with a Jetson NX Production module: How to prepare root fs on microSD card to boot production module from external SD card?

But, the NX is not able to detect a plain ext4 formatted SD card. The SD card is working on other Ubuntu machines, so I believe the issue is with the reader itself. The user mentions editing/replacing the standard dtb file. From other posts, it seems that the sdhci for sdmmc3 is sometimes disabled, so i’m assuming that the dtb file modification enables that?

I checked /proc/ on my jetson and saw that sdhci@3440000 and sdhci@3400000 were disabled and sdhci@3460000 is enabled. I’m using Jetpack 4.6.2, and the dtb file being flashed is the “tegra194-p3668-all-p3509-0000.dtb”. I decompiled it and saw that both 3400… and 34400… had their status set to “disabled”.

My question is: do I just set sdhci@34400… to “okay”, replace the original dtb file, and reflash?

do I just set sdhci@34400… to “okay”, replace the original dtb file, and reflash?

This worked. My NCB00 can detect the SD card slot. For people who also come across this problem, here is what I did:

  1. Flash with your default image and check your flash logs for what dtb files are being used
  2. Go to the proper dtb file and decompile it using dtb: Build dtb files for jetson nano
  3. Look for sdhci@3440000 and set status to “okay”, save and recompile back with the same link in step 2
  4. Replace the old dtb and reflash

Hopefully this doesn’t cause downstream issues.

Glad to know issue resolved, thanks for the sharing!

If anyone is confused on how to get the NX production module with the NCB00 SD card, follow this documentation: https://docs.nvidia.com/jetson/archives/l4t-archived/l4t-3261/index.html#page/Tegra%20Linux%20Driver%20Package%20Development%20Guide/flashing.html#wwpID0E01O0HA

But instead of the given flash command, flash with something like this: sudo BOOTDEV=mmcblk1p1 ./flash.sh -C nv-auto-config jetson-xavier-nx-devkit-emmc mmcblk1p1 where mmcblk1p1 is the SD card. It worked for me.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.