NX with JetPack 5.0.2 poweroff without consent


We’ve installed 5.0.2 on a NX platform and performed minimization steps (mainly removing desktop) as described here: Step 1: Removing GUI - Guide to Minimizing Jetson Disk Usage

Shell commands:

# sudo apt remove ubuntu-desktop* firefox ubuntu-docs libreoffice-* xorg*
# sudo apt autoremove

When using the standard jetpack, the system doesn’t poweroff on its own.
But, with the minimized graphics display it does so after 20 minutes of inactivity, roughly.
We observed, that the minimized version contains different power settings, that tells it to hibernate/go-to-sleep after 20 minutes of idle time.
However, changing that value to never doesn’t completely solve the problem.
As it’s relying somehow on screen activity as well.
Only after we change screen settings to never poweroff, the system runs without interruption.

The kern.log shows exactly the sequence of voltage regulation before powering off.
My questions are:

  • What settings can affect such behavior?
  • How can we change them through command line, assuming now graphics interface exists?
  • Is it possible for future releases to set the settings the other way so that by default it remains powered? As minimization is meant for headless operations.

Many thanks,

We have tried to remove certain not-in-use packages on Jetson Nano:
DS app running on SD, not running on eMMC - Part II - #5 by DaneLLL

You may try this and see if it works:

$ sudo apt remove --purge thunderbird* libreoffice* chromium*

And if you would like to use Jetpack 5.0.2 GA + DeepStream SDK(or CUDA, TensorRT), we would suggest have NVMe SSD for putting rootfs. These packages requires significant storage size and embedded eMMC may not be sufficient.

Thanks for the response.
Please note that my concern is not primarily saving space, but really minimizing the system, to have no user interface in the future. So it is essential to remove ubuntu-desktop as well.
The problem is that with the steps above, something causes the OS to poweroff suddenly, and the reason is unknown to me.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.