Object_id and source id in file name of image save by deepstream-transfer-learning-app is wrong

Hello every one
when i run deepstream-transfer-learning-app with multi sources so i get file name of image does not match the image.
the out put like

… help me

• Hardware Platform (Jetson NX)
• DeepStream 5.0
• JetPack Version 4.4)
• TensorRT 7.1

Can you upload your config file, test videos and rule file(*.csv) so that we can try to reproduce the problem?

1 Like

hello i just change source0 to

uri=file:/opt/nvidia/deepstream/deepstream-5.0/samples/streams/sample_720p.mp4

and source1 to

uri=file:/opt/nvidia/deepstream/deepstream-5.0/samples/streams/sample_qHD.mp4

in ds_transfer_learning_app_example.txt file

@Fiona.Chen can you check it

help me, please
capture_time_rules.csv (169 Bytes) ds_transfer_learning_app_example.txt (4.9 KB)

i has solve this problem by set nvinfer batch-size different streammux batch

I meet the save problem, can you share your solution? thanks!

I have 4 input videos ( all batch-size=1), I set steammux batch-size=4, and primary-gie batch-size=8, but the save image name is still wrong

deepstream_transfer_learning_app_main.cpp (38.4 KB)
can you try with this file

thanks for your response!
I also found the mismatching of ‘source_id’ and ‘batch_id’, I solved this by change the frame_meta befor save image.

NvDsFrameMeta *f_meta = (NvDsFrameMeta*) g_list_nth(batch_meta->frame_meta_list, source_id)->data;

thank you all the same !

1 Like