Object Physics (obj_physics) not working in Replicator Composer. Objects are still flying


I tried the tutorial for Replicator Composer to generate realistic looking synthetic images, but the images produced are still floating and did not look like the images found on the page, where the objects lie neatly on the ground.

What I did is entering these command inside Isaac-Sim terminal:
./python.sh tools/composer/src/main.py --input parameters/warehouse.yaml --output */datasets/warehouse --num-scenes 10 --headless --mount ~/composer-workspace

The tutorial page: 5. Replicator Composer — Omniverse Robotics documentation

Hi there,

to simulate the scene before writing the data, take a look at the example from bullet no, 3.

Here is some more info regarding



I encountered the same issue.
Changing/Adapting parameters for sequence and physics did unfortunately not help.
It seems like the time is frozen at the start of the simulation.
Any suggestions?

Best regards,

Hi Sebastian,

can you check if setting obj_physics to True fixes the issue?


“obj_physics” is set to “True” in “parameters/warehouse.yam”, I did not change that.
Can you tell me what i have to add in order to “simulate the scene before writing the data”?

Best regards,

Can you also check if setting scene_gravity to True changes anything?

Unfortunately, this also changes nothing.
Besides the gravity “not working”: the objects are overlapping, so the physics-engine should detect those collisions and move the objects, right? But they stay in the same place, like time is not moving.

It seems composer.py sets a rigid body to the asset if it contains a obj_vel parmameter.

Can you check adding:

  obj_vel: (0, 0, 0)
  obj_rot_vel: (0, 0, 0)

similar to composer/parameters/flying_things_4d.yaml

I tried that, but got following error:

[Error] [omni.physx.plugin] Physics scenes stepping is not the same, step subscription will be send with later step, per scene step is not yet supported.

Thanks for the various testing, I will go over this with the composer team and will get back to you.

Until then, maybe you can check if setting gravity/physics to the flying_things_4d example will cause the objects to drop.

Thank you for the support, I still get the error mentioned in my last post, but I receive output images that seem to be right!

To sum up, i added:

obj_vel: (0, 0, 0)
obj_rot_vel: (0, 0, 0)

in the “obejcts:” section, and:

sequential: True
sequence_step_count: 5
sequence_step_time: 1
scene_gravity: True

at the end of the “parameters/warehouse.yaml” file.

Not sure if the error might lead to other issues.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.