OC Issues [Kubuntu 17.10] [GTX 1070 Ti] [387.22]

It seems that everybody that uses your desired kind of setup is using the manual driver install using the .run installer with --no-opengl-files option.

I have exactly the same problem. I have two gpus and onborad intel graphics
GPU 0: GeForce GTX 1060 6GB (UUID: GPU-31b1e494-0e2d-3e89-7069-949fa068002f)
GPU 1: GeForce GTX 1070 (UUID: GPU-68e8837f-66e2-3f87-316a-8ce73645539c)

I noticed that the problem happens when I have display connected to the onboard intel and I have two gpus installed. There is no problem to have display connected to the intel and to have only one gpu installed.

Connecting display directly to 1060 solved the problem for me.


Sorry, but I’m still having the same issue, so I kinda just gave up. I have two 1070 Ti’s hooked up with my HDMI going into the onboard intel unit.

It seems there are essentially two options for us (neither which I’ve tried yet):

  1. Manual driver install using the .run installer with “–no-opengl-files” option.
  2. Connect your HDMI to one of the Nvidia cards.


So I eventually got around to it and updated my drivers and plugged my HDMI cable into one of my GPUs. I then set the coolbits option via the nvidia-settings binary and rebooted. Everything worked like a charm after that.

Good luck!