Occasional RTSP stream delay in deepstream

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU) Jetson
• DeepStream Version 6.0.1
• JetPack Version (valid for Jetson only) 4.6.1
• TensorRT Version 8.2.1+cuda10.2
• NVIDIA GPU Driver Version (valid for GPU only)
• Issue Type( questions, new requirements, bugs) questions
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

We encountered a problem that happens when our deepstream pipeline receives an RTSP input.
The first part of our pipeline consists of gstrtspsrc > gstrtph264depay > gstqueue0 > gstdecodebin > gstqueue1.
I monitored the pipeline by probe functions inserted in sink pads of gstqueue0 and gstqueue1.

After a new RTSP session is established, the stream sometimes does not pass through the followed gstdecodebin and the RTSP session is forced to reset due to our implemented timeout of 15 seconds.
So it can take a long time until the stream passes through the gstdecodebin.

Even if the timeout is disabled and the stream passes successfully, it can take over 30 seconds, and at that time there is an error message like

“v4l2bufferpool gstv4l2bufferpool.c:747:gst_v4l2_buffer_pool_alloc_buffer:nvv4l2decoder4:pool:src#033[00m failed to allocate buffer”.

Could you help me find why sometimes the stream at gstqueue0 does not reach gstqueue1 immediately?

There is no update from you for a period, assuming this is not an issue anymore. Hence we are closing this topic. If need further support, please open a new one. Thanks

  1. could you share the whole log? wondering if it is decoding issue. if decoding failed, gstdecodebin will not output data.
  2. how did you do that “our implemented timeout of 15 seconds.”?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.