Oem-setup

what port to listen e.g. by minicom while rflashing the nx device? in order to configure it it via the headless OEM-setup tool?

sudo minicom /dev/ttyACM0 ?
sudo minicom /dev/ttyGS0 ?
in my case, they both two since recent seem to reffer to tty8 port and the oem-configuratino setup will not pop up [ worked previously thougs]

reference: https://docs.nvidia.com/jetson/l4t/index.html#page/Tegra%20Linux%20Driver%20Package%20Development%20Guide%2Fflashing.html%23wwpID0E0WB0HA

It’s going to be an ttyACM device on the host. There’s a note on that page about not using minicom because of utf8 issues. I’ve used putty and cu without issues.

Hi @gtj
Thank you for following up!
However the issue in my case is not with the utf8. I saw the latter before two times and it is still usable with its utf8 issue. It is expressed in part of text interface being reflect in a corrupted way, but it is still possible to get through and finish the setup.
In my case with nx, the issue is that there is no output on /dev/tty8 interface that is being reffered too when I start listening on tty ports. Given the display is detached and the board has just been flashed with headless sdkmanager. In minicom the status is shown as offline.

The status is always going to be offline because there are no control signals (DSR, CD) to tell minicom that it’s connected to anything. That’s OK. I don’t understand the significance of /dev/tty8 . Where do you see it referenced? If there’s a display plugged in the setup will run on /dev/tty7 and there will be consoles started on tty2-tty6 but none of that should be enabled if there’s no display plugged in. The oem-setup should be running on ttyGS0.

A few things to check…

  • Is the baud rate set correctly in minicom? 115200.

  • Can you connect to the serial console port and does it give you the following message on reboot?

Please complete system configuration setup on the serial port provided by Jetson's
USB device mode connection.  e.g. /dev/ttyACMx where x can 0, 1, 2 etc.

Was this a clean SD card image?

No, there is no display connected to the nx device;
Eventually every connection to ACM0 or ttyUSB* port will open the tty8.
No, it was not an empty sdcard. Last two times I re flashed the nx devkit consecutively with sdkmanager to see if the oem setup will pop up in the terminal but it did not occur. Before these two reflashings there were more reflashings with sdkmanager.
Upd: using minicom /dev/tyGS0 will also pop up tty8
Moreover, I shall try to connect to the serial console next time. As I recollect the successful attempts of enetering oem-setup were in case I tried both serial console connection and usb-c connection with minicom. Thank you for sharing the idea!.

How do you know it’s opening tty8? I also don’t understand minicom /dev/ttyGS0 now. That’s the serial port on the NX itself. Are you trying this on the NX itself?? Are you trying to re-run oem-setup? If so, it won’t work because the first time oem-setup is run, it deletes the service files so it can’t be run again.

just to clarify,
execution of minicom /dev/tty* [ here various combinations were tried including ACM* ttyUSB* ttyGS0* and others] will open a minicom terminal that binds to the port tty8 as it listed at the host pc minicom interface.

@gtj, did you succeed getting into the oem-setup dialog after flashing nx devkit with sdkmanager? Or after using the sdcard image restored to an empty sdcard? to a non empty sdcard? In the scenario reffered by you I understand that the minicom hasn’t been used in the successful attempt to open oem-configuration, has it? I understand that putty has been used, right? Under Windows? To which port did you connect with putty from the host pc? I can not run anything from NX locally as it is in remote office. So I can access the Host PC via ssh, from there I am trying to setup the initial user and password. I am trying to access the oem-setup of the nx device from Host PC with Ubuntu. The Host PC is connected with the nx devkit via usb cable that has been used for flashing of the latter using the headless sdkmanager. No display is connected to the nx devkit device. While flashing I was listening with minicom the /dev/ttyACM0 port that opened tty8. Nothing did appear on the finish of the flashing sequence.
However, thank you for the idea. I believe that conenction with serial console via the micro USB port of the AGX will likely resolve the issue.
Do not hesitate to let me know if you have any further questions, please.

Oh I get it now. You need to use the -D option with minicom to get it to bind to a specific device otherwise it defaults to something else. Try this…

minicom -b 115200 -8 -D /dev/ttyACM0

I do NOT use the sdkmanager specifically because of issues like this. Nor do I use Windows. I’m using Fedora32 but the instructions for Ubuntu should be exactly the same. I have used both flash.sh to flash an entire NX and I’ve also written the sd card image directly to an sd card. Neither had issues with headless setup.

On the serial console (via the UART pins on the front panel header) I get this…

[    6.526140] rtk_btusb: fw name is  rtl8822cu_fw
[    6.534152] rtk_btusb: This is not 8723a, use new patch style!
[    7.766635] Please complete system configuration setup on the serial port provided by Jetson's USB device mode connection. e.g. /dev/ttyACMx where x can 0, 1, 2 etc.

I can then see a new /dev/ttyACMn device on the host and can connect to it using minicom, putty (for linux), cu, etc.

Thank you for sharing.

it works perfectly on NX devkit;
sudo picocom -b 115200 /dev/ttyACM0
tested with sdkmanager installation;
However, it doesn’t appear to work with AGX Xavier Jetson from the first attempt
Eventually, it started to work from the third attempt at AGX.

it doesn’t work when the NX sdcard is restored from the sdcard image
It would show:

~$ sudo picocom -b 115200 /dev/ttyACM0
[sudo] password for greensightag: 
picocom v2.2

port is        : /dev/ttyACM0
flowcontrol    : none
baudrate is    : 115200
parity is      : none
databits are   : 8
stopbits are   : 1
escape is      : C-a
local echo is  : no
noinit is      : no
noreset is     : no
nolock is      : no
send_cmd is    : sz -vv
receive_cmd is : rz -vv -E
imap is        : 
omap is        : 
emap is        : crcrlf,delbs,

Type [C-a] [C-h] to see available commands

Terminal ready
localhost login: nvidia
Password: 

Login incorrect
localhost.local.tld login: nvidia
Password: 

Login incorrect
localhost.local.tld login: ubuntu
Password: 

Login incorrect
localhost.local.tld login: 
FATAL: term closed

Is there any way to use the headless oem setup for nx device with OS recovered from sdcard image?


from local witnesses

 after power cycling the screen just keep flashing
inbetween flashing I can see on the top it says something i2c error

Hi,

May I know what does that mean " OS recovered from sdcard image"?

Hi WayneWWW,
Thank you for your response.
In the given context it means the OS from jetson nx sdcard image that opposes to the method from flashing OS with sdkmanager or flash.sh.

Ok, are you sure this is a pure and latest sdcard image from our website?

We just resolved another oem-config issue on Nano sdcard, and it turns out this user does not use latest image.

md5sum nv-jetson-nx-sd-card-image-r32.4.2.zip
4b24e23867ed3d4b651934d0ac40c92c  nv-jetson-nx-sd-card-image-r32.4.2.zip

does it seem like the latest one?

Yes, it looks the latest one.

What is your connection? Do you connect the usb typeC cable to the flash port?

I believe that it was micro usb-B cable conencted to the NX devkit. The other side of the cable was conencted to Host PC with ubuntu. However, Ii was a remote setup. I had to ask a colleague to do manual user/password creation.
Just before the attempt with sdcard-image-based-OS it was tried with sdkmaanger image & oem-setup and it turned out to work persistently. Means oem–setup worked multiple times consequtively.
Upd: I have just downloaded a file nv-jetson-nx-sd-card-image-r32.4.2b.zip, it has b added in the name, but it has the same checksum:
4b24e23867ed3d4b651934d0ac40c92c

Hi,

I don’t get your exact question. Have you ever see the " Welcome to Jetson Initial Configuration " on ttyACM0?

Please note that you shall not see the login prompt on ttyACM0. It should only show up on ttyUSB0.

"Terminal ready
localhost login: nvidia
Password: "

Hi,
Thank you for your response.

  • installing OS on NX with sdkmanager
    I was able to see the " Welcome to Jetson Initial Configuration " on ttyACM0

  • recovering with dd the sdcardimage to sdcard
    I was not able to see the message;
    The question is whether the oem-setup works with the latest sdcard image distribution of the OS? Is it an issue specific to the image or to my setup? That is what I am trying to understand.

I guess maybe dd has some problem. We will try it on our side too.

Could you also try etcher?