OFED Driver can't load(probe) as module auxiliary is conflicted with intel's net diver

I can’t properly install OFED 5.7 or 5.4 dirver on my system after I had installed intel i40e/ice driver.
I got the error message when I run [/etc/init.d/openibd restart] to load driver:
[root@localhost MLNX_OFED_LINUX-5.4-]# /etc/init.d/openibd restart
Unloading auxiliary [FAILED]
rmmod: ERROR: Module auxiliary is in use by: ice

I found the reason is that the OFED dirver and i40e driver all have a module auxiliary installed, and the two “auxiliary.ko” is conflict.

I tried the latest dirver and got the some result. Is there any fix or any proper way to use both driver/device ?

the restart include stop and start.
if you don’t need stop, then just need to start as
/etc/init.d/openibd start

if have to stop, could you stop ice related module first?
As you know, the error is raised by kernel protection mechanism.
“rmmod: ERROR: Module auxiliary is in use by: ice”


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.