OFED NVMET and NVMET-RDMA on Ubuntu symbol errors

Hello, I tried installing ofed on unbuntu 20.04. I had issues inserting nvmet and nvmet-rdma. I know ubuntu 20.04 was only somewhat supported so i tried 19.10 but i am having the same issues.

basically i have tried the following install methods, they all install fine without error, but they all result in the same two errors:

ERROR: could not insert ‘nvmet_rdma’: Unknown symbol in module, or unknown parameter (see dmesg)

modprobe: ERROR: could not insert ‘nvmet’: Unknown symbol in module, or unknown parameter (see dmesg)

[ 2498.908659] nvmet: Unknown symbol nvme_find_pdev_from_bdev (err -2)

[ 2585.306697] nvmet: Unknown symbol nvme_find_pdev_from_bdev (err -2)

[ 2678.580571] nvmet: Unknown symbol nvme_find_pdev_from_bdev (err -2)

[ 2764.312226] nvmet: Unknown symbol nvme_find_pdev_from_bdev (err -2)

i tried running the install

./mlnxofedinstall --with-nvmf

./mlnxofedinstall --add-kernel-support --with-nvmf

./mlnxofedinstall --add-kernel-support --with-nvmf

i tried with and without dkms as well, same error each time. This is a brand new install of 19.10, so was 20.04 so i am really not sure whats wrong here. Im also not clear what the correct install switches are at this point since none seem to work.

Hello Grant,

Thank you for posting your inquiry on the Mellanox Community.

I was able to replicate this situation on a clean install of Ubuntu 20.04, booting off of an NVME drive.

Replication steps were as follows:

./mlnxofedinstall --with-nvmf

/etc/init.d/openibd restart

modprobe nvmet

Resolution was to rebuild the initramfs, and reboot the system

update-initramfs -u


This is occurring because your initramfs was generated before the Mellanox modules were installed - so the system is still booting using the inbox nvme module (which is incompatible with the newly built nvmet module).

Thank you,

Mellanox Technical Support