Official Jetson Nano Developer Kit does not work on Jetson Nano, but Armbian works

I was able to boot my Jetson Nano (945-13450-0000-100) last week using the 4.5 version of the Jetson Nano Developer Kit SD Card Image. However, after an update (sudo apt update and sudo apt upgrade), the reboot was stuck on the Nvidia logo. I tried version 4.3 of the Developer Kit and got the same issue. I tried 3 different SD cards and still no luck.

To test if the issue was dev kit related, I burned the Armbian for the Jetson Nano on one of the SD cards I tested earlier and - lo and behold! - it booted! Photos below.

Given that my Nano boots using Armbian, I don’t think it is a hardware issue but an OS issue. Any tips on how to get the official Jetson Nano Developer Kit working on it? I need CUDA and cuDNN so I need the official dev kit working on it.

Please find a x64 ubunut 18.04 host and flash your board with sdkmanager.

1 Like

Will do.

Hello @UpbeatAds
The problem becomes from “sudo apt upgrade”

If you upgrade or dist-upgrade your Jetson, it can not boot successfully again. The upgrade step crashes the current packages.

Can you try without sudo apt upgrade command. Hope it will work


1 Like

Will try