Older versions of CUDA (pre 11.7) with Ubuntu 22.04

I have some old (but essential) binaries that are compiled against CUDA 10.2. These require libraries such as libnppc.so.10, etc.

The nVidia repository for Ubuntu 22.04 only contains packages for CUDA 11.7.

Is there a recommended way of installing older versions of CUDA? I’m currently working around this by copying libraries from an Ubuntu 18.04 machine, but would like a more robust solution.

TIA.